Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm totally a beginner, so I hope someone can answer this question in plain English. I'm using Ubuntu 12.04. I have a Canon lpb 2900. I downloaded the driver as in the documentation, extracted the deb and ran it with Ubuntu Software Center. Then I got this:

Screenshot of error

I tried something from the old questions of this site but they didn't work.

share|improve this question
    
did you tried installing .tar.gz package? –  ashutosh May 1 '12 at 14:28
    
looks like processor issue.Please check the version of the package if it is compatible with your processor –  ashutosh May 1 '12 at 14:33

1 Answer 1

Looks like you are trying to install an i386 package on an amd64 system. And the package wasn't designed to be installable on amd64.

I suggest trying to convert one of the 64-bit RPMS to a deb with alien.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.