Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Am struggling to install vmtools on a ubuntu 10.04 server guest on my esxi server. I have tried the "Install VM Tools" option but that does nothing. I have tried running the apt-get install vmware-tools but get the message that there are no packages. Has anyone managed to do this as it is driving me nuts?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

When you use the "Install VM Tools" action a virtual media should be available from the cdrom from the guest OS (the cdrom is attached to the vmware tools iso). Because you are using a server install (no cdrom auto mount magic) you will need to manually mount the cdrom:

sudo mkdir /mnt/cdrom
sudo mount /dev/cdrom /mnt/cdrom

Check the contents from /mnt/cdrom, there is a binary that you will need to execute to install the tools (I don't have vmware installed right now to check).

share|improve this answer
    
This is what happens when trying to do work stuff late at night after a full day! thanks very much for the nudge in teh right direction! –  Tim Alexander Nov 15 '10 at 11:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.