Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I had a working Ubuntu 10.04 desktop with ATI drivers with three monitors on a Radion HD 5750.

After a standard apt-get update; apt-get upgrade; reboot

I got a black screen (system booted, but graphics did not display at login screen). I went into recovery mode and reset to basic graphics mode.

Currently, the Catalyst control center says the ATI driver is not installed. But the "hardware drivers" tool (jockey) says "ATI Fire GL" is installed and in use.

So either: 1. The driver is not actually installed even though jockey claims it is, or 2. The driver is installed but catalyst can't find/use it.

I used apt-get to purge and then reinstall the ATI drivers with no improvement.

How do I get this driver working again? Is there a way to completely purge/remove everything graphics related and start over like a clean system, but without an OS reinstall?

share|improve this question
up vote 3 down vote accepted

Jockey re-downloads everything on every driver re-install as far as I know.

Use jockey to remove the driver, reboot, re-install the driver also through jockey, and you should be fixed.

This is a common problem for people that compile the latest ATI driver themselves. If you did that, you need to remove all the self-compiled components so that jockey and the jockey installed amdcccle appear first in your search path and just work.

share|improve this answer
I tried uninstalling and reinstalling through Jockey too, but that had no effect. I don't believe that I compiled the driver myself... but how can I check to see if I have "self-compiled components" installed just to be sure? – Nick Apr 29 '12 at 1:27
if you remove it through jockey and running amdcccle produces a dialog, you have self compiled components – RobotHumans Apr 29 '12 at 1:29
I removed the driver with jockey and still get an error when running amdcccle. So I guess I do have self compiled components somewhere. How do I find and get rid of them? – Nick Apr 29 '12 at 2:10
which amdcccle should tell you where it is. an ls -la in that directory should tell you where the link goes. I can't see that directory listing so saying delete everything there is a not okay thing to do, but you need to delete everything related to the self-compiled driver. – RobotHumans Apr 29 '12 at 2:12
which amdcccle shows /usr/bin/amdcccle which is a symlink to /etc/alternatives/amdcccle which is a symlink to /usr/lib/fglrx/bin/amdcccle. /usr/lib/fglrx/bin/amdcccle appears to be the actual executable file. Do I want to remove /usr/lib/fglrx? – Nick Apr 29 '12 at 3:00

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.