Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

i am trying to run an executable file from ubuntu 11.10, and this happens for several different files.

i try to run the file and it says "no such file or directory"

it is not the file because the file was downloaded from a package only, and the exact file runs fines on three of my friends computers. i have recently re installed a new partition of ubuntu 11.10.

it is not a permissions issue because I've tried running it as sudo and ive tried chmod and ive edited the permissions of the actual file to give myself permission and allow it to be run as an executable.

my only guess is that there is some deep setting in Ubuntu somewhere that is accidently activated which prevents me from running executable. i have seen this same question asked in several places and never receive a satisfactory answer. does anyone know why ubuntu is doing this?

please help as soon as possible, i need this program to run today. this is a major ubuntu problem and prevents me from doing anything on this OS.

the code i am running is a simple *.sh function. i navigate to the folder and type ./

and it executes the file fine. that file calls another executable within a folder in that directory called bin. before doing so, it adds bin to the $PATH so thats not an issue. but when it tries to call that executable, it says it cannot find the file. here is the code of the


SDKPATH=$(dirname $(readlink -f $0))

# Edit this script as you want :)

$SDKPATH/bin/urbi-launch --start $UOBPATH/* -- --host --port 54000 -f 

its not just this file however. ive gon into several other files and tried running executables in a similar manner and the same error comes up. again these same files are executed fine in other computers with the same commands. the only difference is that they have WUBI installed and i am using a partition. i dont know what the issue could be.

share|improve this question
Hi jimmy. Where are these executables in the file system, and what exact process (commands please) are you using to try to run them? Please edit them into your question with four spaces indent before each command. – Jjed Apr 29 '12 at 1:11
What happens if you manually launch the program instead of using the start script? in other words, run urbi-launch followed by balltracking.u. Do you get the same error from both commands? – Scott Severance Apr 29 '12 at 8:34

Assuming it is both urbi-launch and balltracking.u that are problems, I suggest you try this for each of these two scripts. First go to the directory in which the script resides. Do an ls -Ll <script> and confirm that script grants you execute permissions. The Ll is upper and lower case "el", which give you permissions and traces a symlink in case the script is a link. This guarantees you get the permission on the script and no accidentally the link.

If the permissions look right, then try running each script as a command by invoking it as ./<script>.

If that works, then it is not a problem with Ubuntu, the script executes correctly. If it does not execute correct, please provide the permissions listing and the results of the id command so we can see what you are too.

If the script work from the command line, then it is your script that has a problem. Have it echo the paths so you can see what is really being used. Another approach to narrow down to the setting of paths is to hard code the explicit path in for each of the other scripts. If that works, you are guaranteed the problem is in your scrip and how you determine the path.

Last, I strongly recommend you adopt the following stype for variables in scripts, use ${variable} instead of $variable because adding the curly braces guarantees that other characters are not accidentally added to the variable name creating a new variable with no value.

share|improve this answer

Perhaps your executable is 32-bit, and you don't have the 32-bit libraries installed.

Install them with: sudo apt-get install ia32-libs

share|improve this answer
Assuming you're running on a 64-bit platform like I was! – Sam Finnigan Nov 17 '13 at 19:22
ia32-libs is no longer required to run 32-bits in 64-bits versions of Ubuntu. BTW, that link is from 2009... all information relevant with architecture of binaries became obsolete with the introduction of Multiarch. – Braiam Nov 17 '13 at 19:46
Ok, that's fair. But that's what fixed this problem for me on 12.04. – Sam Finnigan Nov 20 '13 at 10:29
mm... you notice that the question is for 10.10? – Braiam Nov 20 '13 at 13:52
The question was for 11.10, yes. Multiarch would definitely be supported. I'm confused though as to why installing ia32-libs fixed this exact problem for me on 12.04-- it does still exist as a convenience package to install common 32-bit libs. Perhaps the answer should read ia32-libs-multiarch instead? Let me know what you think it should say. Thanks. – Sam Finnigan Nov 20 '13 at 14:48

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.