Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just upgraded my Ubuntu to 12.04, and somehow its lost keyboard and mouse support, Logitech EX110 Cordless, preventing me from logging in, both the main and recovery mode won't respond to any keys at all, the previous kernal recovery mode does see the keyboard. Can I reverse this fatal upgrade somehow? Using the 12.04 live CD does work, but upon trying a reinstall, it hangs on "reinstalling previously installed packaged", which don't seem to install because "You have held broken packages".

share|improve this question
    
askubuntu.com/questions/125903/… –  user58853 Apr 30 '12 at 18:52
add comment

4 Answers

Upon upgrade I was unable to use my Logitech MX550 wireless keyboard and mouse.

Using information from this site, I was able to gain full use of my mouse and keyboard as follows:

  1. I booted into Ubuntu 12.04 on my desktop.
  2. Booted into Ubuntu on my laptop.
  3. Used ssh on my laptop to log into my desktop.
    • After logging in via ssh but before performing step 4, you may need to use lsusb to determine your receiver's product ID. Mine is c71[34]. Another user with a similar situation had product ID c52b.
  4. Created a new file with the command:

    sudo nano /etc/udev/rules.d/97-bluetooth-hid2hci.rules
    
  5. Added the following lines to the file:

    ACTION=="remove", GOTO="hid2hci_end"
    SUBSYSTEM!="usb", GOTO="hid2hci_end"
    
    # Logitech devices
    KERNEL=="hidraw*", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c71[34]", \
    RUN+="hid2hci --method=logitech-hid --devpath=%p"
    
    ENV{DEVTYPE}!="usb_device", GOTO="hid2hci_end"
    
    LABEL="hid2hci_end"
    
    • If your product ID is not c71[34], then replace that with your product ID (which you may have obtained with lsusb as described above).
  6. Saved the file.
  7. Reloaded the rule as root with:

    sudo udevadm control --reload-rules
    
  8. Rebooted the desktop to find my mouse and keyboard working (instead of rebooting, reattaching the keyboard/mouse dongle works too).

*alternately you can run the following to reset the dongle

modprobe -r hid_logitech_dj
modprobe hid_logitech_dj
share|improve this answer
add comment

I was having the same problem with my MBP running Ubuntu. Here's what I did -- hopefully it'll work for you. I solved these problems, but right now my monitor isn't playing nice with it, so I still have to fix that.

First of all, on boot, press "e" when selecting your partition to edit the boot parameters. Look for something that says "quiet splash" and confirm that "text" is not appended to the end of that. Shouldn't be by default, but I had added it at one point.

Second, boot. When the Ubuntu logo splash screen pops up, press Ctrl+Alt+F1 (you might also need the Function key pressed if you're on a laptop). In the terminal, login and run

sudo apt-get -f install

This will probably run for awhile, so let it go. Hopefully your computer's fans will be working (at this point, I noticed mine didn't, and I received a warning during the update that my CPU temperature was above the threshold and that the clock would be throttled. If that happens, try this -- it should work for your computer. If you're on a Mac, you'll have to do something slightly different.

Your networking probably won't be working, either, but after the apt-get command runs, reboot and it should work again.

After that process, my computer is running it fine, though I have to manually watch the temperature and set the fans accordingly. My only problem was one time that my monitor went blank, as though it had set the display to sleep mode.

share|improve this answer
add comment

I had a similar problem but couldn't get a usable console like previosly described.

Instead I made a 12.04 USB boot image. Due to the fact that this image did actually work on my laptop Asus EEE 1215B I continued opening a terminal (Ctrl-Alt-T) from where I was able to mount my harddisk (see /etc/fstab for details) Om my PC it was /dev/sda1.

So I did:

sudo mkdir /tmp/xx
sudo mount /dev/sda1 /tmp/xx

Afwards I made a

sudo - root
chroot /tmp/xx

I then made an

su - 'mynormalusername'

followed by

export PATH=/sbin:$PATH
sudo apt-get install -f

This one halted at some point due to 'too many errors'. I tryed a couple of times but didn't seem to come any further so I tryed rebooting. And guess what, I can use my PC again.

share|improve this answer
1  
sudo doesn't accept a - option. Running sudo - root yields the error sudo: -: command not found. You may want to edit your answer to change this to whatever command accomplishes what you're trying to do. (I'm not sure exactly what you're trying to do, which is why I have not made this change myself. But it seems to me that you could just put sudo in front of the chroot command and delete the sudo - root command from your instructions altogether.) –  Eliah Kagan Jun 11 '12 at 19:58
add comment

I had the same issue. It is likely that the upgrade was interrupted and hence did not complete (which was what had happened in my case as my system crashed during upgrade). At the command prompt, please type:

sudo dpkg --configure -a

It will install the rest of the upgrades and once you reboot, the issues are resolved.

share|improve this answer
add comment

protected by Community Jun 11 '12 at 20:03

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.