Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to install Ubuntu 12.04 Server (32bit) on a machine here using a USB stick. I used the Universal-USB-Installer-1.8.9.4 which has support for 12.04 server to get the ISO onto the USB drive.

  1. The computer boots up the installation process ok.
  2. It gets through the Ubuntu language, locale and keyboard selection.
  3. Then starts loading additional components. At this point it gets about a quarter of the way through then throws big error message saying:

[!!] Load installer components from CD

There was a problem reading data from the CD-ROM. Please make sure it is in the drive. If retrying does not work., you should check the integrity of your CD-ROM.

Failed to copy file from CD-ROM. Retry?

cd rom error with purple background

Retrying obviously fails as well. Have tried re-running again and installing again onto the USB but no change. Have tried checking for CD-ROM integrity errors and it breaks on this error:

[!] Check the CD-ROM(s) integrity

Integrity test failed

The ./pool/main/l/linux/fs-secondary-modules-3.2.0-23-generic-pae-di_3.2.0-23.36_i386. file failed the MD5 checksum verification. Your CD-ROM or this file may have been corrupted.

enter image description here

Have also tried the Ubuntu-Server 12.04 LTS (Precise Pangolin) daily build. No go there. Even checked the iso SHA1 hashes and they match.

Have tried LinuxLive USB Creator 2.8.11 and unetbootin-windows-575 to see if it was an image with the USB drive software but still no go.

Any ideas?

share|improve this question
2  
This bug also affects ubuntu-12.04.2-server-amd64.iso and there is a bug filed in bugs.launchpad.net/debian-installer/+bug/1130381 –  Omid Kosari Apr 24 '13 at 12:01
3  
I encountered this problem whilst trying to install ubuntu-12.04.2-server-amd64. A solution that worked for me was to use Win32 Disk Imager to write the ISO to the USB flash drive. When I opened the ISO image in 7-zip, or mounted it using Daemon Tools and viewed the contents in Windows Explorer, both showed the files in /pool/main/l/linux with truncated names. –  NickG Jun 22 '13 at 15:59
1  
NickG's solution worked for me as well (had used UNetbootin under Windows first which apparently didn't work). –  gablin Aug 2 '13 at 11:10
    
I experienced the same issue but with 13.10. Turns out the problem was not with the installer but the motherboard's BIOS settings (GIGABYTE GA-990FXA-UD3). I was unable to install from USB and ended up cloning an existing server installation and boot the computer with it. Neither the USB ports nor the Ethernet card would work. Once the BIOS settings were changed everything started working. See askubuntu.com/questions/276788/… for details –  hknust Dec 11 '13 at 4:27

7 Answers 7

up vote 21 down vote accepted

It seems there are some naming errors with the files under \pool\main\l\linux (I found false extensions *.ude instead of *.udeb there) and a MD5-Checksum error with ./install/netboot/ubuntu-installer/i386/pxelinux.cfg/default). After fixing these errors I'm able to install the 32-bit Server Edition.

share|improve this answer
1  
Thanks! Yeah they are definitely in the ISO image like that. Strangely I managed to get it working by simply burning to DVD even without renaming the files to their proper extension. Installing from USB though must pick up the errors. –  zuallauz Apr 30 '12 at 11:41
1  
Kudos @hre1. There have been issues with USB installs for several years. No one has really fixed this or fully identified them. The only work around, for those few machines that always stalled during install, was to use a CD-ROM instead. –  david6 Jun 3 '12 at 0:04
1  
MAYBE: If the USB is stick created under the same Ubuntu release as the target, then this will often work (even when a 'Universal' created stick fails). eg. using 12.04 LTS 'desktop' to create USB install for 12.04 LTS 'server'. The bugs need to be fixed, but this minimises them .. –  david6 Oct 25 '12 at 8:14
1  
I don't have any *.ude file instead of *.udeb in \pool\main\l\linux –  Open SEO Dec 27 '12 at 15:53
1  
just changing the extension works, look for them. I found them and just renamed the extension and everything worked like a charm. –  Basit Anwer Jan 2 '13 at 17:21

This was my solution with a Ubuntu 12.04 LTS server installation from a USB Pendrive:

  • Run the installer.
  • Open a shell (ALT + F2).
  • Create the directory cdrom directly on the root of the file system:

    mkdir /cdrom
    

    (If you got problems making the directory /cdrom, disable the CD-rom player in BOIS or disconnect the cable)

  • Mount the USB as if it is a CD-ROM:

    mount -t vfat /dev/sdb1 /cdrom 
    

    Where sdb1 is your USB device.

That's all.

share|improve this answer
1  
Once you've remounted, you can get back to the install screen by pressing Alt-F1. –  jevon May 27 '13 at 5:41

The solution is to use the Startup Disk Creator. I have try it on my USB key and I have installed Ubuntu Server 12.04 LTS 32 bits without trouble. I use Ubuntu Desktop 12.04 LTS in order to create my USB Startup Disk. See this article for details about Startup Disk Creator: http://www.ubuntu.com/download/help/create-a-usb-stick-on-ubuntu

share|improve this answer
    
I just tried this method, and it does indeed work, so +1 for that... However, I wouldn't call this the solution, as there's clearly a problem with either the Ubuntu disc image or the Universal USB Installer program. –  Breakthrough May 8 '12 at 16:11
    
This method is quite valid. But, I am concerned that this (quietly) forces a workaround. These are still a few machines out there (older BIOS, chip) where the SDC/USB method does NOT work, and one has to resort to a CD install. –  david6 Jun 3 '12 at 0:06
    
This isn't a solution if you only have a windows box –  Open SEO Dec 27 '12 at 15:54

For me it was enough to change those extensions (*.ude to *.udeb) under \pool\main\l\linux.

share|improve this answer
    
For me too. I'm glad I found this thread before pulling all of my hair out. –  Drew Noakes Oct 24 '12 at 21:29
2  
cd into the pool/ directory and run find . -name "*.ude" -exec mv {} {}b \; to fix them all. :) –  gertvdijk Aug 28 '13 at 18:10

I found another solution to this. Follow the steps:

  • create the bootable pendrive as using Universal-USB-Installer-1.8.9.4
  • also copy the same iso file to the pendrive
  • reboot the system and select Execute shell command
  • run the following command (mind the device/pendrive name):

    mount -o loop /dev/sdb1 /cdrom
    exit
    
  • select the option load configuration from cdrom

  • a list of options will be shown; select the 3rd,4th and 5th which are related to loading iso
  • now on main menu select option load iso from disk
  • a list of disks will be shown, select the one corresponding to your pendrive
  • the iso file will be shown select this and you are done
  • follow the rest of onscreen options
share|improve this answer
    
Aha! -- There it is. Filenames are truncated at 64 characters. The solution by Ajay worked for me. –  user67984 Jun 2 '12 at 23:02

Here the issue (broken installer image on usb for 10.04 64b server) was solved by using the startup disk creator on an existing 12.04 installation (edu i386). The startup disk creator on Ubuntu 10.04.4 LTS 64b, caused the damaged startup-usb and does not seem to be compatible (enough) to create a 12.04 installation usb-stick.

share|improve this answer

I used the current version of PendriveLinux for windows (1.8.9.6) and I also had this problem. Creating the bootable usb stick with the Startup disk creator solved my issuse.

share|improve this answer

protected by Community Jan 28 '13 at 13:45

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.