Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Macbook Pro 6,2 running OSX 10.6.8, Windows 7, and Ubuntu. I use reFit to be able to choose which one to boot but I've never had a problem with reFit in the past. I was running Ubuntu 11.10, but just upgraded today to 12.04. I'm quite excited to try it out, after hearing about some of the improvements and additions.

I installed and rebooted, and no errors were displayed during this process. After restarting, I edited my grub the way I normally do (I have an option that I enabled on grub that hasn't been working and I keep forgetting to change it, so I have to do it each time on boot). Anyway, the keyboard worked just fine at that point (it had to, because I typed with it), but after hitting ctrl+X and initializing the boot, it seems to stop working. No messages pop up, but then it gets to the login screen and the icons in the top show the "image not found" icon ( http://www.aerotaskforce.com/thumb/Capturar.JPG/w/150 ) and no input devices work. The built-in trackpad does not allow me to move the mouse and doesn't seem to register anything (the mouse is stuck in the middle of the screen), and the keyboard doesn't allow me to type in my password.

So, I had to manually restart by hitting the power button, and this time I chose recovery mode. However, even then, I didn't see any problems. The only error I got was that "pty" failed.

Is there any way I can fix this without having to reinstall the entire OS from scratch?

*EDIT :: *

I determined that this is Unity and not the keyboard drivers, because they work on grub and in command line, when I managed to boot into that. Booted into command line and ran "sudo apt-get -f install" and it ran for about ten minutes, during which I noticed that my fans don't work an Ubuntu anymore either. So, in trying to install the ability to manually control my fans, I determined that my network card is not recognized anymore, either, and I can't apt-get install anything. So, whatever it was, I broke everything.

During the apt-get -f install process, I got this message: "temperature above threshold cpu clock throttled"

share|improve this question

1 Answer 1

up vote 1 down vote accepted

The solution to the temperature issue on the Macbook Pro (6,2) was to create a script to self monitor it. That's the best I could come up with. First, install lm-sensors via apt-get, and then run sudo sensors-detect and answer yes to all the questions and everything. Then sensors should return your hardware settings. The script is something along the lines of:

sensors | grep --color="none" "Core"
sensors | grep --color="none" "side"
if [[ $1 < 6001 && $1 > 1999 ]]
    then
    sudo echo $1 > /sys/devices/platform/applesmc.768/fan1_min
    sudo echo $1 > /sys/devices/platform/applesmc.768/fan2_min
fi

The first command will return both your CPU temperatures, and the second will return your current fan speed. Then we do a sanity check to make sure that you don't accidentally add a 0 and try to run your fans at 60,000 RPM (the fans might have something built-in to prevent this, but I didn't want to take a chance on blowing them up, because that would be very awkward to explain.

Name that script something like spoolFTL or whatever you like. Then, you can set the fan speed to a number, x, by running sudo bash spoolFTL 4500. The directory is relative, though, so you might consider putting it in the root directory so you can run sudo bash /spoolFTL 4500.

apt-get -f install fixed the networking and keyboard and such. Unity doesn't freeze at login, but it does crash after awhile (usually 10 minutes), and I have to do a hard reset. Console still works fine, though.

Edit: In my experience, I've been keeping the CPU at around 45°C to keep it happy. In command line, 2000 RPM has been enough to keep it at this temperature quite easily (as in OSX), but when I start Unity, I have to generally run it about 4000-4500 RPM (probably about the same in 11.10, as well). I imagine this is due to the high CPU requirements of the Unity desktop. When I first started Unity, I kept it at 3000 and thought it would be enough. A few minutes of Firefox browsing later, I checked it and my CPUs were at 75°.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.