Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've changed my Unity launcher from super to alt+F1 because I (used to) set a lot of commands with super keybindings. It appears to not work at all in Ubuntu 12.04.

Is there a solution ?

Thanks !

OT: also, ctrl+alt+q fails since ctrl+q closes the gnome control center...

share|improve this question
add comment

2 Answers 2

up vote 0 down vote accepted

Replacing "super" with "Mod4" in ~/.gconf/desktop/gnome/keybindings/custom0/%gconf.xml seems to work for me. There might be compatibility issues if you bind already existing shortcuts, say "Mod4+Tab".

"Alt+.." doesnt work either (after restarting X) for me. I have no solution for that. Why they dont put all shortcuts in the same place is beyond me... One place where every app could read/write the same shortcuts.. but that's another issue.

share|improve this answer
    
Thanks, looks like it works ! It's not ... straight forward, to say the least, but it works. It's now labeled as 'super+hyper' in the gnome-control-center.. –  user50745 Apr 29 '12 at 18:43
add comment

Install CompizConfig Settings Manager (CCSM)

sudo apt-get install compizconfig-settings-manager

Open CCSM from System Tools>Preferences>CompizConfig Settings Manager

Open "Commands" under the General group. Enable by check marking the box on the left.

Log off, log on. (Restart X)

share|improve this answer
    
Shoud that alone make the gnome control center "super" bindings work ? Or are you suggesting to set keybindings in Compiz-Commands instead ? Because I already have "Commands" enabled and Im using it for "edge" bindings. Im afraid the limit of 20 commands isn't enough for me. –  user50745 May 1 '12 at 18:07
    
+1 for this finally helping to "fix" ubuntu 12.04. Unity's behavior with the super key is annoying at best, bizarre otherwise. I use Autokey-QT and "launchers" to do all sorts of useful things with the Super key, which Unity has undone. :P –  Chris K Jun 11 '12 at 20:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.