Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After I upgraded to the latest version, and I'm fully up to date, I can no longer burn CDs or DVDs, the OS simply will not recognize any blank media. Has anyone else been experiencing this and if so have you found a solution?

share|improve this question

closed as too localized by Luis Alvarado Mar 14 '13 at 16:30

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
I had this problem too. –  User Aug 6 '10 at 17:00

6 Answers 6

There has been a documented issue with this on the previous version of ubuntu. If you had upgraded your system the problem may still be persistent, simply due to the nature of the upgrade.

I would recommend a clean install.

share|improve this answer
    
I did a clean install and I had this problem too. –  User Aug 6 '10 at 17:00
    
Ditto. I did a clean install and I still can't burn. –  Erigami Aug 6 '10 at 21:49

Does it detect other CD/DVD media? if not then problem lies with CD/DVD drive - the hardware.

share|improve this answer

I think this is a wide spread issue - there are lots of forum threads (eg. http://ubuntuforums.org/showthread.php?t=1544152, http://ubuntuforums.org/showthread.php?t=1539292) with similar issues.

It may help to update your kernel. Go to System -> Administration -> Update Manager and update all of your packages.

If there is no improvement, try installing the package linux (to install the latest kernel).

If there is still no improvement, you may need to use a ppa to install a newer kernel, that is not available from the repositories. I hear version '2.6.35' solves this issue with some people.

To install it, you need to add the repository: ppa:kernel-ppa/ppa to your software sources. Then install: linux-headers-2.6.35-14, linux-headers-2.6.35-14-generic and linux-image-2.6.35-14-generic.

share|improve this answer

I Had the same troubles and did a firmware update with the DVD/CD-Drive and everything works well.

share|improve this answer

I always get this problem when the laser optics start to get dirty. It would read OK but not recognize blank media let alone try to burn them. A quick blast of air always fixed the problem. Get a can of compressed air and try it.

share|improve this answer

You do not give any clue what hardware you have. I had that problem (and suspend/hibernate issue) on an old Dell Inspiron 8200 laptop. It had a hot swap drive bay that had a DVD drive in it. But apparently because it could be hot swapped, Linux kept polling for a floppy drive, resulting in log errors attempting to read fd0, lack of auto mounting USB or CD/DVD's, and failed to suspend or hibernate because it could not put udisks-deamon to sleep, which kept polling for the non-existing floppy.

So if you have no floppy and are getting any fd0 errors in dmesg or /var/log/messages similar to "end_request: I/O error, dev fd0, sector 0", either disable the floppy in your BIOS, or if that does not work:

Add following to /etc/modprobe.d/blacklist.conf (use sudo or gksu to run your editor):

blacklist floppy

Then do: sudo update-initramfs -u

Then reboot and see if USB and other removable media auto mounts when inserted.

Note that other partitions on internal drives are not auto mounted unless you make proper mount points (usually in /media unless you want it mounted elsewhere) and entries in /etc/fstab (preferably using UUID). Although, they will mount if you have permission and select them in Places.

share|improve this answer