Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Writing this from an older Dell Notebook, ugpraded to 12.04 32-Bit, which works well.

My more modern Dell Notebook worked well for 1/2 day after upgrading to 12.04 64-Bit, now I'm having problems logging in:

System boots normally, (Unity) can enter my password, the login-screen reports 'Logging in....', but that's the end, won't log in even after 30 minutes - it just stays on the login screen. Same for guest login.

Console log in works well and quick. Checked Xorg.0.log.old, but didn't see an error message. The user:group for my home directory is correct. An fsck didn't find any errors.

Will need to find out how to mount an USB stick from command line, sure you'll want me to upload log files...

Thanks tino

share|improve this question

closed as off topic by Jorge Castro, fossfreedom May 14 '12 at 9:20

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Seems to be the same problem as this one: askubuntu.com/questions/126275/… . Found that - while the 'Logging in....' hangs - using Shutdown/Restart from the panel and retrying the login, after the second or third time, the login does work. Strange. –  cbourbou Apr 29 '12 at 5:45
    
This question should instead be filed as a bug report, thanks! Instructions here. –  Jorge Castro May 14 '12 at 4:56

4 Answers 4

I found that when I set: Ubuntu Tweak, Login Settings, "Set the same background as the current desktop background" (I also have "Draw Grid" ON, but that was ON before), the login screen then actually does not show my current background but the purple default - however, when before it took me 2-4 cycles of shutdown/login to actually log in, with the changes I was able to login 5x in a row without problems.

share|improve this answer

I quote: System boots normally, (Unity) can enter my password, the login-screen reports 'Logging in....', but that's the end, won't log in even after 30 minutes - it just stays on the login screen. Same for guest login.

I found a silly solution: Don't press ENTER after your login password but press the character > at the end of the button.

share|improve this answer
    
Notebook in the office currently - will test it after my 1 week vacation. (and I assume you mean pressing the '> area' with the mouse, not hitting the key >) ......Thanks for the tip! –  cbourbou Apr 29 '12 at 16:09
    
Yes, pressing the '> area'. –  Roberto Bello Apr 29 '12 at 17:00
    
Tried the '>' solution, did not work in my environment. –  cbourbou May 8 '12 at 11:53
    
There is a bug open for this: bugs.launchpad.net/unity-greeter/+bug/986967 . Looks like the patch does work already, will wait until it is included in normal SW-Update, since I have a workaround.... –  cbourbou May 8 '12 at 13:39
    
The bug description hints that the problem occurs if you set "Play login sound" (did it via UbuntuTweak) to OFF. I've reverted it to ON and am able to login without delay. –  cbourbou May 10 '12 at 12:40

I am using Dell Vostro 3350 laptop. Dual boot Windows 7 and Ubuntu 12.04 64 bit (Fresh install).

Same problem at login screen. After keying in password and pressing enter, stuck indefinitely at "Logging in".

Using mouse to click the arrow instead of pressing enter did not work for me.

If key in a wrong password on purpose, system recognises the wrong password immediately. Shows "Invalid password, please try again".

Guest account is stuck at "Logging in" as well.

Update: after a few reboots, login works. then problem return at next reboot.

Update2: I gave up. Did a fresh install of Ubuntu 12.04, and problem has not resurface since.

share|improve this answer

After the SW-Update this morning (which included Xorg components), the problem seems to be gone. Reverted my login-screen settings and was able to login a couple of times without any problems. Will observe over the coming days, but expect no more problems.

share|improve this answer
    
Alas, this morning, I had to recycle my notebook 6 time before I passed the login screen. So the SW-Update did not solve the problem. Btw: The solution with pressing the '>' with the mouse doesn't work in my environment. –  cbourbou May 8 '12 at 9:37

Not the answer you're looking for? Browse other questions tagged or ask your own question.