Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Rhythmbox's not playing music from network share. When you move seekbar, you can hear sound for half a second though, but then it stops.

Plays music just fine from mounted drives. Also tested with Banshee and VLC player: both played files with no problems.

System: clean-installed 12.04

share|improve this question
    
This appears to relate to the question I asked: askubuntu.com/questions/124229/rhythmbox-playing-without-sound. I am playing from a network share too.... –  Dries May 4 '12 at 10:09
    
God, how I wish mainstream desktop linux could get past the stage where the below shenanigans are necessary for something so basic.. –  LOAS Feb 23 at 19:00

4 Answers 4

I had the same problem; now fixed. As Dries says, the solution was to mount the share... but then I also had to use the dconf-editor and set org.gnome.rhythmbox.rhythmdb/locations to the mount directory. Simply using the Rhythmbox Music->Import Folder menu item only resulted in import errors being generated regardless of whether I directed it to a Nautilus 'bookmark' of the share or to a manually mounted share.


Setting up the share mount

First, install samba and cifs:

sudo apt-get update
sudo apt-get install samba cifs-utils

Then determine the IP address for your server. In this case, mine is called myserver:

nmblookup myserver

Which will output something like this:

querying myserver on 192.168.1.255
192.168.1.10 myserver<00>

You're looking at the second line of the output for the IP address of the server. Then edit your fstab file to automatically mount the share on that server each time your computer starts up. In this case, my share is called databox:

sudo gedit /etc/fstab

And insert this line at the bottom of the fstab file:

//192.168.1.10/databox /mnt/databox cifs noauto,guest 0 0

Now mount the share for this session:

sudo mount /mnt/databox

...and check that there are no errors. Your share should be listed when you type:

df -h

and you should be able to navigate to the share and view its contents:

cd /mnt/databox
ls

If you've had errors at this point, you need to review the contents of your fstab file.

Note that this method assumed that your server doesn't have a DHCP IP address assigned to it by your router. You might need to 'fix' the IP address in your router configuration before proceeding. Also, if your network share requires a userid and password, you may need to change the guest option to something similar this.


Mounting automatically on each boot

Unless you want to have to manually mount the share after every boot with sudo mount /mnt/databox, you also need to set up a script to automatically mount your share:

cd /etc/NetworkManager/dispatcher.d
sudo gedit mountnfs

...and put the following into your script:

mount /mnt/databox

Reboot your system, and then check that the share has been mounted successfully with:

df -h

Note that Network Manager is the Ubuntu default. If you're using a different network tool, you could try placing this script into /etc/network/if-up.d/ instead. You can't just set the fstab share option to auto, because Linux tries to mount drives before it sets up networks. Other potential approaches for this stage might be to:

  1. include the _netdev option in fstab. However, this apparently doesn't work until you run systemctl enable NetworkManager-wait-online.service, which requires systemd, which isn't fully compatable with Ubuntu.
  2. use autofs and automount, which apparently can hang the system on shutdown.

Getting Rhythmbox to recognise the music on your share

Now install and run the dconf-editor:

sudo apt-get install dconf-tools
sudo dconf-editor

Navigate through the tree to org.gnome.rhythmbox.rhythmdb and find the locations setting. Then change this setting to something like:

['file:///mnt/databox/Music']

...check the monitor-library tickbox... and you're done! (fingers crossed)


NB: I'm using Rhythmbox 2.97 on Ubuntu 12.10 with Network Manager 0.9.6.0-0ubuntu7

share|improve this answer

I had the same issue (music was skipping a lot) even after I mounted the CIFS share. The solution I found is to add cache=loose in the mount options. Note that using this option can have drawbacks if the files are accessed by multiple users at the same time. Read man mount.cifs for more information on CIFS caching.

I'm using Rhythmbox 2.99.1.

share|improve this answer

This has been reported as a rhythmbox bug https://bugs.launchpad.net/ubuntu/+source/rhythmbox/+bug/977866

If you mount the share to the local file system it works fine. (make sure to remove the database and re-import all songs from the new location)

share|improve this answer

I created a symbolic link from my share in ~/.gvfs and then navigated via the symbolic link and was able to play the .mp3 files. I.e.,

ln -s ~/.gvfs/user on blah/BarenakedLadies/ ~/foo
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.