Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Gnome-terminal doesn't start when I click it from the dash. When I open x-term and try to start it from there, I get"floating point exception (core-dumped)". But I could start gnome-terminal as root. So what's going on? And how do I fix it?

share|improve this question
2  
I would advice filing a bug report towards gnome-terminal. I have not seen any error like this reported towards gnome-terminal so it might be something new. –  Rinzwind Apr 28 '12 at 19:49
    
and in the mean time, ctrl + alt + t –  Dr_Bunsen Jun 2 '12 at 16:53
    
@Dr_Bunsen Why would Ctrl+Alt+T help? On a GNOME-based desktop (like Unity), that will just open gnome-terminal. –  Eliah Kagan Jun 2 '12 at 17:18
add comment

2 Answers 2

Given your description, it is almost certain that gnome-terminal is starting, but always crashes. (You won't see the crash message if you start it from the dash.) I recommend enabling Apport crash reporting and then reporting a bug. To report the bug, read this page first, then try to run gnome-terminal, then let Apport submit information to Launchpad automatically and fill out the bug report in your web browser when it comes up.

The information sent to Launchpad when Apport automatically reports the crash is necessary for your bug report (for a crash, like this) to be useful. It's possible to manually generate this information, but there is very little reason to do so, since Apport does the job quite well.

share|improve this answer
    
Sure, I've already sent a bug report. In the meantime, I guess I'll try out guake –  tamimym Apr 29 '12 at 3:07
add comment

Since this is one of the first pages that appears when searching for this problem, and there is no actual solution to it, I thought of posting one that worked for me.

-- This should only work if you tinkered with fonts by using Ubuntu Tweak --

So, if you did do that, go to MyUnity, go to the fonts tab, and select Default Settings. After the fonts have been returned to normal, the terminal will start working again.

At least that did the trick for me.

Props go to Knurveren for the fix.

Cheers!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.