Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Just installed Ubuntu 12.04, but when i'm trying to boot desktop in normal mode screen turns black, just black (like turned off), but when I'm trying to boot in secure mode top half of screen start twitch and flick, bottom is black. How can I solve this problem? Netbook Acer Aspire One 751h | Intel GMA500

share|improve this question

6 Answers 6

I've installed a "fresh" Ubuntu 12.04 in my Acer Aspire One 751H, and I've the same problem.

Follow the steps to fix the issue:

  • Open your Terminal - Ctrl + Alt + F1

  • Restart X:

    sudo service lightdm restart
    
  • Open /etc/default/grub:

    gksu gedit /etc/default/grub
    

    and change

    GRUB_CMDLINE_LINUX_DEFAULT=”"
    

    to

    GRUB_CMDLINE_LINUX_DEFAULT=”quiet console=tty1 acpi_backlight=vendor acpi_osi=Linux acer_wmi.blacklist=yes mem=1920mb”
    

Now it should work.


Source: Ubuntu Wiki and Bodhizazen Blog

share|improve this answer

This is a known compatibility issue with 12.04 and some restricted graphics drivers. The most likely cause is a

/etc/X11/xorg.conf

file that remained after the upgrade. Try booting into the 11.10 Live CD and disabling any proprietary drivers, which should fix it. Hope this helps!

share|improve this answer

just press button Fn+Left arrow or Right arrow while booting starts and that's it ! if its for acer laptop

share|improve this answer

I had exactly the same issue on an Alienware M18x (2 x ATI cards in there). Using the above answer (thanks to fjt) I booted to recovery mode, enabled networking (which re-mounts the filesystems for you in r/w mode) and dropped to a root prompt.

I edited (using vi) /boot/grub/grub.cfg and changed the linux /vmlinux-3.2.0.24-generic to add on the end, "acpi_backlight=vendor acpi_osi=Linux" (ignore the quotes)

Saved and rebooted. All kicked into life for me. I do have a long standing issue where on shutdown it hangs so I have to force it down, but other than this all is ok.

share|improve this answer

Using Xubuntu 12.04 on an Acer Aspire One 751h (1 GB RAM) the solution

GRUB_CMDLINE_LINUX_DEFAULT="quiet console=tty1 acpi_backlight=vendor acpi_osi=Linux acer_wmi.blacklist=yes mem=896mb"

Worked fine for me.

  1. Edit GRUB as root using your favourite editor eg. in a terminal sudo joe /etc/default/grub

  2. Change the GRUB_CMDLINE_LINUX_DEFAULT to the above string

  3. Save, sudo update-grub and reboot.

Contains the solution from Bodhizazen.net

share|improve this answer
    
Your kind words are appreciated. My intention was not to get my entry up or down, but thru to the interested ubuntu user with the same type of computer and problem. I am surprised finding myself on the wrong side by just sharing information others sparing a reasonable time of fiddling with parameters. –  UbuntuSane Feb 8 '13 at 22:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.