Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I just upgraded to 12.04. When I press the super key to open the dash, there's a lag of 1-3 seconds before it displays, with no other programs running. (This is similar, but not identical, to the issue described in Dash application search unresponsive at startup about 11.10.) At login time, this lag is up to 10 seconds, and sometimes the dash doesn't respond at all to the super key.

In contrast, the launcher Kupfer immediately responds to its hotkey, in milliseconds, and responds to my typing an application name also in fractions of a second.

Is there a way to load the dash in memory or a RAM disk of some sort to make it more responsive?

share|improve this question
add comment

marked as duplicate by Stephen Myall, Florian Diesch, qbi, Eliah Kagan, belacqua Feb 26 '13 at 21:34

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

5 Answers

up vote 12 down vote accepted

Use Compiz config setting manager and go to:

Ubuntu Unity Plugin -> Experimental -> Dash Blur

Setting it to No blur improved thing massively for me.

share|improve this answer
add comment

The always present problems with Dash performance are ridiculous. If they can't make it snappy, why they use effects at all?!

As for the original question - unfortunatelly you may experience this https://bugs.launchpad.net/ubuntu/+source/linux/+bug/990002 or a simillar bug.

No bugs but still not snappy?

After using Unity for months in a relatively bug-free environment on a dedicated graphics I can say this:

  1. Even on best software/hardware configurations Unity will feel slow. Smooth but slow. This is due to long animations, the most important of which can't be tweaked or disabled How to disable all Unity animations?
  2. The simplest tweaks to improve Dash responsiveness is to disable blur and use Dash at its desktop size i.e. not maximized. Maximized Dash takes twice as long to open even on strong hardware. Disabling online search results may also help.
share|improve this answer
add comment

Similar to iain's answer, you can also use Ubuntu Tweak to modify those settings.

  • Open Ubuntu Tweak (which can be launched either from the dash, or in the System Settings)
  • Open the tab Tweaks and click Unity
  • Set the Blur type to no blur
share|improve this answer
    
Changing the panel and launcher opacity to 1.00 may also affect performance (at least from a rendering point of view), but I'm afraid I haven't done any actual performance comparisons to see if there is a noticeable difference. –  IQAndreas Jan 15 '13 at 23:29
add comment

You can also use MyUnity to change the settings for the Dash.

Open up MyUnity, click on the "dash" tab and select "Off" on the "Blur" settings drop down box.

Additionally also experimenting with settings under "launcher" might help.

share|improve this answer
add comment

I had similar troubles. Using the Compiz Config Settings Manager (ccsm) I modified the window fade-in/out values, everything is responding faster.

share|improve this answer
    
that makes the lag go away, but it also cancels the animation. –  Marius Balaban Apr 28 '12 at 20:39
2  
I don't see an option for dash-related fade-in/out values. There are options for the menu fade times, but not for the dash, as far as I can tell. –  Jon Apr 29 '12 at 23:30
    
I too don't see any dash-related fade in/out values in ccsm. Could you expand on your answer a bit please? –  Gabriel Dec 5 '12 at 14:55
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.