Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Background:

I have a server running ClearOS, operating as my print server (among other services). Back when I was using Ubuntu 10.04, I was able to print to it fine. Fast forward, I've upgraded to Ubuntu 12.04 64 Bit via a fresh install, and now when I follow the wizard to setup an IPP printer, my documents won't print (though they work from other clients fine). Any ideas?

Here are the client logs:

==> access_log <==
localhost - - [28/Apr/2012:12:41:28 -0500] "POST /printers/HL-2140 HTTP/1.1" 200 284 Create-Job successful-ok
localhost - - [28/Apr/2012:12:41:28 -0500] "POST /printers/HL-2140 HTTP/1.1" 200 14145 Send-Document successful-ok

==> error_log <==
E [28/Apr/2012:12:41:33 -0500] [Job 9] Unable to add document to print job.

==> access_log <==
localhost - - [28/Apr/2012:12:41:35 -0500] "POST / HTTP/1.1" 200 345 Create-Printer-Subscription successful-ok
localhost - - [28/Apr/2012:12:41:35 -0500] "POST / HTTP/1.1" 200 345 Create-Printer-Subscription successful-ok

==> error_log <==
W [28/Apr/2012:12:42:34 -0500] failed to CreateProfile: org.freedesktop.ColorManager.AlreadyExists:profile id 'HL-2140-Gray..' already exists
W [28/Apr/2012:12:42:34 -0500] failed to CreateDevice: org.freedesktop.ColorManager.AlreadyExists:device id 'cups-HL-2140' already exists

==> access_log <==
localhost - ksoviero [28/Apr/2012:12:42:45 -0500] "POST / HTTP/1.1" 200 186 Renew-Subscription successful-ok

Here are the server logs:

==> /var/log/cups/access_log <==
10.0.0.170 - - [28/Apr/2012:12:44:30 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 400 0 unknown-0000 -
10.0.0.170 - - [28/Apr/2012:12:44:30 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 621 Get-Printer-Attributes successful-ok
10.0.0.170 - - [28/Apr/2012:12:44:30 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 262 Validate-Job successful-ok
10.0.0.170 - - [28/Apr/2012:12:44:30 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 262 Create-Job successful-ok
10.0.0.170 - - [28/Apr/2012:12:44:30 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 654 Get-Printer-Attributes successful-ok
10.0.0.170 - - [28/Apr/2012:12:44:30 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 369 Get-Job-Attributes successful-ok

==> /var/log/cups/error_log <==
E [28/Apr/2012:12:44:30 -0500] cupsdReadClient: 12 IPP Read Error!
I [28/Apr/2012:12:44:30 -0500] [Job 91] Adding start banner page "none".
I [28/Apr/2012:12:44:30 -0500] [Job 91] Queued on "Brother_HL-2140_series_USB_1" by "ksoviero".

==> /var/log/cups/access_log <==
10.0.0.170 - - [28/Apr/2012:12:44:30 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 426 577419 Send-Document successful-ok
10.0.0.170 - - [28/Apr/2012:12:44:31 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 369 Get-Job-Attributes successful-ok
10.0.0.170 - - [28/Apr/2012:12:44:31 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 654 Get-Printer-Attributes successful-ok
10.0.0.170 - - [28/Apr/2012:12:44:31 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 369 Get-Job-Attributes successful-ok

==> /var/log/cups/error_log <==
E [28/Apr/2012:12:44:31 -0500] Send-Document: Unauthorized
I [28/Apr/2012:12:44:31 -0500] cupsdCloseClient: SSL shutdown successful!
I [28/Apr/2012:12:44:31 -0500] cupsdCloseClient: SSL shutdown successful!

==> /var/log/cups/access_log <==
10.0.0.170 - - [28/Apr/2012:12:44:32 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 369 Get-Job-Attributes successful-ok
10.0.0.170 - - [28/Apr/2012:12:44:32 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 654 Get-Printer-Attributes successful-ok
10.0.0.170 - - [28/Apr/2012:12:44:32 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 369 Get-Job-Attributes successful-ok

==> /var/log/cups/error_log <==
I [28/Apr/2012:12:44:32 -0500] cupsdCloseClient: SSL shutdown successful!

==> /var/log/cups/access_log <==
10.0.0.170 - - [28/Apr/2012:12:44:33 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 369 Get-Job-Attributes successful-ok

==> /var/log/cups/error_log <==
I [28/Apr/2012:12:44:33 -0500] cupsdCloseClient: SSL shutdown successful!

==> /var/log/cups/access_log <==
10.0.0.170 - - [28/Apr/2012:12:44:34 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 654 Get-Printer-Attributes successful-ok
10.0.0.170 - - [28/Apr/2012:12:44:34 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 369 Get-Job-Attributes successful-ok
10.0.0.170 - - [28/Apr/2012:12:44:35 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 369 Get-Job-Attributes successful-ok

==> /var/log/cups/error_log <==
I [28/Apr/2012:12:44:35 -0500] cupsdCloseClient: SSL shutdown successful!

==> /var/log/cups/access_log <==
10.0.0.170 - - [28/Apr/2012:12:44:37 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 654 Get-Printer-Attributes successful-ok
10.0.0.170 - - [28/Apr/2012:12:44:37 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 369 Get-Job-Attributes successful-ok
10.0.0.170 - - [28/Apr/2012:12:44:38 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 369 Get-Job-Attributes successful-ok

==> /var/log/cups/error_log <==
I [28/Apr/2012:12:44:38 -0500] cupsdCloseClient: SSL shutdown successful!

==> /var/log/cups/access_log <==
10.0.0.170 - - [28/Apr/2012:12:44:42 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 654 Get-Printer-Attributes successful-ok
10.0.0.170 - - [28/Apr/2012:12:44:42 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 369 Get-Job-Attributes successful-ok
10.0.0.170 - - [28/Apr/2012:12:44:43 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 369 Get-Job-Attributes successful-ok

==> /var/log/cups/error_log <==
I [28/Apr/2012:12:44:43 -0500] cupsdCloseClient: SSL shutdown successful!

==> /var/log/cups/access_log <==
10.0.0.170 - - [28/Apr/2012:12:44:50 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 654 Get-Printer-Attributes successful-ok
10.0.0.170 - - [28/Apr/2012:12:44:50 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 369 Get-Job-Attributes successful-ok
10.0.0.170 - - [28/Apr/2012:12:44:51 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 654 Get-Printer-Attributes successful-ok
10.0.0.170 - - [28/Apr/2012:12:44:51 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 369 Get-Job-Attributes successful-ok
10.0.0.170 - - [28/Apr/2012:12:44:51 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 369 Get-Job-Attributes successful-ok

==> /var/log/cups/error_log <==
I [28/Apr/2012:12:44:51 -0500] cupsdCloseClient: SSL shutdown successful!

==> /var/log/cups/access_log <==
10.0.0.170 - - [28/Apr/2012:12:44:52 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 654 Get-Printer-Attributes successful-ok
10.0.0.170 - - [28/Apr/2012:12:44:52 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 369 Get-Job-Attributes successful-ok

==> /var/log/cups/error_log <==
I [28/Apr/2012:12:44:52 -0500] cupsdCloseClient: SSL shutdown successful!

==> /var/log/cups/access_log <==
10.0.0.170 - - [28/Apr/2012:12:44:52 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 369 Get-Job-Attributes successful-ok
10.0.0.170 - - [28/Apr/2012:12:44:54 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 369 Get-Job-Attributes successful-ok
10.0.0.170 - - [28/Apr/2012:12:44:54 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 654 Get-Printer-Attributes successful-ok
10.0.0.170 - - [28/Apr/2012:12:44:54 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 369 Get-Job-Attributes successful-ok

==> /var/log/cups/error_log <==
I [28/Apr/2012:12:44:53 -0500] cupsdCloseClient: SSL shutdown successful!

==> /var/log/cups/access_log <==
10.0.0.170 - - [28/Apr/2012:12:44:56 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 369 Get-Job-Attributes successful-ok

==> /var/log/cups/error_log <==
I [28/Apr/2012:12:44:56 -0500] cupsdCloseClient: SSL shutdown successful!

==> /var/log/cups/access_log <==
10.0.0.170 - - [28/Apr/2012:12:44:57 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 654 Get-Printer-Attributes successful-ok
10.0.0.170 - - [28/Apr/2012:12:44:57 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 369 Get-Job-Attributes successful-ok
10.0.0.170 - - [28/Apr/2012:12:44:59 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 369 Get-Job-Attributes successful-ok

==> /var/log/cups/error_log <==
I [28/Apr/2012:12:44:59 -0500] cupsdCloseClient: SSL shutdown successful!

==> /var/log/cups/access_log <==
localhost - - [28/Apr/2012:12:45:02 -0500] "POST / HTTP/1.1" 200 316 Get-Jobs successful-ok
localhost - - [28/Apr/2012:12:45:02 -0500] "POST / HTTP/1.1" 200 414 CUPS-Get-Printers successful-ok
localhost - - [28/Apr/2012:12:45:02 -0500] "POST / HTTP/1.1" 200 414 CUPS-Get-Classes successful-ok
localhost - - [28/Apr/2012:12:45:02 -0500] "POST / HTTP/1.1" 200 72 CUPS-Get-Default client-error-not-found
localhost - - [28/Apr/2012:12:45:02 -0500] "POST / HTTP/1.1" 200 225 CUPS-Get-Printers successful-ok
localhost - - [28/Apr/2012:12:45:02 -0500] "POST / HTTP/1.1" 200 316 Get-Jobs successful-ok
localhost - - [28/Apr/2012:12:45:02 -0500] "POST / HTTP/1.1" 200 414 CUPS-Get-Printers successful-ok
localhost - - [28/Apr/2012:12:45:02 -0500] "POST / HTTP/1.1" 200 414 CUPS-Get-Classes successful-ok
localhost - - [28/Apr/2012:12:45:02 -0500] "POST / HTTP/1.1" 200 72 CUPS-Get-Default client-error-not-found
localhost - - [28/Apr/2012:12:45:02 -0500] "POST / HTTP/1.1" 200 412 CUPS-Get-Printers successful-ok
localhost - - [28/Apr/2012:12:45:02 -0500] "POST / HTTP/1.1" 200 316 Get-Jobs successful-ok
localhost - - [28/Apr/2012:12:45:02 -0500] "POST / HTTP/1.1" 200 414 CUPS-Get-Printers successful-ok
localhost - - [28/Apr/2012:12:45:02 -0500] "POST / HTTP/1.1" 200 414 CUPS-Get-Classes successful-ok
localhost - - [28/Apr/2012:12:45:02 -0500] "POST / HTTP/1.1" 200 72 CUPS-Get-Default client-error-not-found
localhost - - [28/Apr/2012:12:45:02 -0500] "POST / HTTP/1.1" 200 316 Get-Jobs successful-ok
10.0.0.170 - - [28/Apr/2012:12:45:02 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 654 Get-Printer-Attributes successful-ok
10.0.0.170 - - [28/Apr/2012:12:45:02 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 369 Get-Job-Attributes successful-ok
localhost - - [28/Apr/2012:12:45:02 -0500] "POST / HTTP/1.1" 200 316 Get-Jobs successful-ok
localhost - - [28/Apr/2012:12:45:02 -0500] "POST / HTTP/1.1" 200 414 CUPS-Get-Printers successful-ok
localhost - - [28/Apr/2012:12:45:02 -0500] "POST / HTTP/1.1" 200 414 CUPS-Get-Classes successful-ok
localhost - - [28/Apr/2012:12:45:02 -0500] "POST / HTTP/1.1" 200 72 CUPS-Get-Default client-error-not-found
localhost - - [28/Apr/2012:12:45:02 -0500] "POST / HTTP/1.1" 200 225 CUPS-Get-Printers successful-ok
localhost - - [28/Apr/2012:12:45:02 -0500] "POST / HTTP/1.1" 200 316 Get-Jobs successful-ok
localhost - - [28/Apr/2012:12:45:02 -0500] "POST / HTTP/1.1" 200 414 CUPS-Get-Printers successful-ok
localhost - - [28/Apr/2012:12:45:02 -0500] "POST / HTTP/1.1" 200 414 CUPS-Get-Classes successful-ok
localhost - - [28/Apr/2012:12:45:02 -0500] "POST / HTTP/1.1" 200 72 CUPS-Get-Default client-error-not-found
localhost - - [28/Apr/2012:12:45:02 -0500] "POST / HTTP/1.1" 200 412 CUPS-Get-Printers successful-ok
localhost - - [28/Apr/2012:12:45:02 -0500] "POST / HTTP/1.1" 200 316 Get-Jobs successful-ok
localhost - - [28/Apr/2012:12:45:02 -0500] "POST / HTTP/1.1" 200 414 CUPS-Get-Printers successful-ok
localhost - - [28/Apr/2012:12:45:02 -0500] "POST / HTTP/1.1" 200 414 CUPS-Get-Classes successful-ok
localhost - - [28/Apr/2012:12:45:02 -0500] "POST / HTTP/1.1" 200 72 CUPS-Get-Default client-error-not-found
localhost - - [28/Apr/2012:12:45:02 -0500] "POST / HTTP/1.1" 200 316 Get-Jobs successful-ok
10.0.0.170 - - [28/Apr/2012:12:45:04 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 369 Get-Job-Attributes successful-ok

==> /var/log/cups/error_log <==
I [28/Apr/2012:12:45:04 -0500] cupsdCloseClient: SSL shutdown successful!

==> /var/log/cups/access_log <==
10.0.0.170 - - [28/Apr/2012:12:45:10 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 654 Get-Printer-Attributes successful-ok
10.0.0.170 - - [28/Apr/2012:12:45:10 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 369 Get-Job-Attributes successful-ok
10.0.0.170 - - [28/Apr/2012:12:45:11 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 654 Get-Printer-Attributes successful-ok
10.0.0.170 - - [28/Apr/2012:12:45:11 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 369 Get-Job-Attributes successful-ok
10.0.0.170 - - [28/Apr/2012:12:45:12 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 369 Get-Job-Attributes successful-ok
10.0.0.170 - - [28/Apr/2012:12:45:12 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 654 Get-Printer-Attributes successful-ok
10.0.0.170 - - [28/Apr/2012:12:45:12 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 369 Get-Job-Attributes successful-ok

==> /var/log/cups/error_log <==
I [28/Apr/2012:12:45:12 -0500] cupsdCloseClient: SSL shutdown successful!

==> /var/log/cups/access_log <==
10.0.0.170 - - [28/Apr/2012:12:45:13 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 369 Get-Job-Attributes successful-ok

==> /var/log/cups/error_log <==
I [28/Apr/2012:12:45:13 -0500] cupsdCloseClient: SSL shutdown successful!

==> /var/log/cups/access_log <==
10.0.0.170 - - [28/Apr/2012:12:45:14 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 369 Get-Job-Attributes successful-ok
10.0.0.170 - - [28/Apr/2012:12:45:14 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 654 Get-Printer-Attributes successful-ok
10.0.0.170 - - [28/Apr/2012:12:45:14 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 369 Get-Job-Attributes successful-ok

==> /var/log/cups/error_log <==
I [28/Apr/2012:12:45:14 -0500] cupsdCloseClient: SSL shutdown successful!

==> /var/log/cups/access_log <==
10.0.0.170 - - [28/Apr/2012:12:45:16 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 369 Get-Job-Attributes successful-ok

==> /var/log/cups/error_log <==
I [28/Apr/2012:12:45:16 -0500] cupsdCloseClient: SSL shutdown successful!

==> /var/log/cups/access_log <==
10.0.0.170 - - [28/Apr/2012:12:45:17 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 654 Get-Printer-Attributes successful-ok
10.0.0.170 - - [28/Apr/2012:12:45:17 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 369 Get-Job-Attributes successful-ok
10.0.0.170 - - [28/Apr/2012:12:45:19 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 369 Get-Job-Attributes successful-ok

==> /var/log/cups/error_log <==
I [28/Apr/2012:12:45:19 -0500] cupsdCloseClient: SSL shutdown successful!

==> /var/log/cups/access_log <==
10.0.0.170 - - [28/Apr/2012:12:45:22 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 654 Get-Printer-Attributes successful-ok
10.0.0.170 - - [28/Apr/2012:12:45:22 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 369 Get-Job-Attributes successful-ok
10.0.0.170 - - [28/Apr/2012:12:45:24 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 369 Get-Job-Attributes successful-ok

==> /var/log/cups/error_log <==
I [28/Apr/2012:12:45:24 -0500] cupsdCloseClient: SSL shutdown successful!

==> /var/log/cups/access_log <==
10.0.0.170 - - [28/Apr/2012:12:45:30 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 654 Get-Printer-Attributes successful-ok
10.0.0.170 - - [28/Apr/2012:12:45:30 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 369 Get-Job-Attributes successful-ok
10.0.0.170 - - [28/Apr/2012:12:45:31 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 654 Get-Printer-Attributes successful-ok
10.0.0.170 - - [28/Apr/2012:12:45:31 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 369 Get-Job-Attributes successful-ok
10.0.0.170 - - [28/Apr/2012:12:45:32 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 369 Get-Job-Attributes successful-ok
10.0.0.170 - - [28/Apr/2012:12:45:32 -0500] "POST /printers/Brother_HL-2140_series_USB_1 HTTP/1.1" 200 654 Get-Printer-Attributes successful-ok

==> /var/log/cups/error_log <==
I [28/Apr/2012:12:45:32 -0500] cupsdCloseClient: SSL shutdown successful!
I [28/Apr/2012:12:45:32 -0500] [Job 91] Adding end banner page "none".
E [28/Apr/2012:12:45:32 -0500] [Job 91] No files, canceling job!
I [28/Apr/2012:12:45:32 -0500] cupsdCloseClient: SSL shutdown successful!
share|improve this question

closed as off topic by fossfreedom May 22 '12 at 18:28

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
If anyone else is affected by this. I have opened a bug report for it here: bugs.launchpad.net/ubuntu/+source/cups/+bug/990734 –  Soviero Apr 28 '12 at 20:57

2 Answers 2

I have a similar problem I can't print from ubuntu 12.04 to a windows printer that is connected via Samba. This worked fine previously on ubuntu 11.10.

The thing I do not understand is that there is no "real" error message since it says for example "Send-Document successful-ok". Even the user authentication works fine.

share|improve this answer

(forget it, I saw later in your bug report that it also fails with x86 architecture)

Assuming that your Ubuntu 10.04 install was 32 bits flavor, your driver probably need some 32 bits library dependancy. The various Brother printers (HL-4070, HL-3040 and HL-4150) I used with Ubuntu had such a problem, CUPS would instantly report printed successfuly but the printer would'nt do anything.

sudo apt-get install ia32-libs
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.