Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgraded to Ubuntu 12.04, and the splash screen does not appear anymore. Instead I have a black screen even if the system boots correctly.

Does any body knows how to fix this.

share|improve this question
    
Same problem for me, it happened after 1. I reinstalled windows, in dual boot, 2. I reinstalled grub, 3. I followed instructions to fix ugly boot screen (news.softpedia.com/news/…) Before that it was all working ok, my guess is that one of the steps described in the guide is no longer valid for 12.04... –  Victor P. Apr 29 '12 at 13:39
    
@VictorP. It seems likely that the reverse of what you did, using the same utility, might solve this problem. I'd suggest posting that as a possible answer. –  Eliah Kagan Aug 6 '12 at 4:13
add comment

5 Answers 5

I had this kind of problem. Here is my solution: The only thing that you may do is that, reboot your system, and run it in recovery mode, then go to clean option and let system remove some unusable files. Good luck!

share|improve this answer
add comment

I had the same problem then I found the solution at http://byobu.info/wiki/Changing_Plymouth_Resolution_in_Ubuntu. It works for my Ubuntu 12.04.

share|improve this answer
2  
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Javier Rivera May 2 '12 at 16:53
add comment

I had the same problem.

I fixed it by repairing packets in the recovery mode. The recovery mode of the new kernel (3.2) did not work, so I had to take the old kernel (3.0).

It turned out to be the solution for my problem. I hope this helps, but maybe you have other problems.

Sidenotes:

  1. The startup process was still damn slow, because the network configuration needed time ( http://www.codewhirl.com/2011/10/ubuntu-11-10-waiting-up-to-60-more-seconds-for-network-configuration/ ). So be sure to give the black screen enough time to start.
  2. Upgrading with sudo aptitude upgrade (or the same with apt-get) helped to get rid of some other error messages.
share|improve this answer
add comment

In normal situation,option of splash screen enabling is placed within boot parameters of your operating system..it means you can interrupt boot process and manually enter params or change your boot params in boot configuration file. if you are using grub/burg run this command to edit:

sudo gedit /boot/grub/grub.cfg

or

sudo gedit /boot/grub/burg.cfg

and add splash to rest of line begins with linux /boot/vmlinuz ..blah blah

and finally it looks like:

linux /boot/vmlinuz-3.2.0-23-lowlatency root=UUID=d0433a6a-d031-4a59-bbb4-d77557235afa ro quiet splash acpi_backlight=vendor $vt_handoff

as you see theres splash within that line. some other reason is your graphic mode cant be enable during boot process and its not much important at all

share|improve this answer
add comment

I got an splashscreen after a Ubuntu server 12.04 installation, and it seems nothing happens, but I think the newest kernels have moved the video mode setting into the kernel.

How I fixed it:

  1. after system-reboot press F6 to get the grub-boot-screen.
  2. edit the first entry in the grub-list to start the system.
  3. edit the /etc/default/grub file
    3.1. in my case i have to set the GRUB_GFXMODE
    3.2. others change these values to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"
  4. run 'sudo update-grub' and reboot

If these won't help, you can find help in the Ubuntu wikis

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.