Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Well i'm new in this site and i have some problems with Ubuntu 12.04

I made a clean installation and install gnome 3.4, gnome classic and cinnamon but when i want to run gnome tweak tool in gnome 3.4, it closes immediately, in Unity, Cinnamon and gnome classic it runs perfectly.

Also I always receive a warning about Ubuntu crashed and sometimes it reboots Can you help me in this?

share|improve this question
    
run gnome tweak tool from terminal and post the output here –  Ashu Apr 28 '12 at 17:06
    
well i saw what's the problem, i have installed the gnome extension "user theme" and it prevented to run the program, after i unistalled it, gnome tweak tool runs in gnome 3.4, but about the crashes in ubuntu 12.04, is it unstable yet? –  Erimatai Santos Apr 28 '12 at 18:51
    
ok, i'll see it, it can be, well thanks for helping me –  Erimatai Santos Apr 28 '12 at 21:12

1 Answer 1

If you try running it from an terminal and you get this error:

(gnome-tweak-tool:4506): GLib-GIO-ERROR **: Settings schema 'org.gnome.shell.extensions.user-theme' is not installed
Trace/breakpoint trap (core dumped)

Then you can run the following two commands from a terminal to add the schema to the system:

sudo cp $HOME/.local/share/gnome-shell/extensions/user-theme@gnome-shell-extensions.gcampax.github.com/schemas/org.gnome.shell.extensions.user-theme.gschema.xml /usr/share/glib-2.0/schemas
sudo glib-compile-schemas /usr/share/glib-2.0/schemas

To run gnome-tweak-tool from the command line start Terminal and just type:

gnome-tweak-tool

And press enter

share|improve this answer
1  
Excellent, thank you so much. I'll update the answer with the complete error message so it's easier to find via Google et al. –  marcvangend May 1 '12 at 12:09
    
while doing your suggested command i get this error No such file or directory. Becuase before coming to this thread I read on some other ubuntu forum that i should to delete .local/share/gnome-shell/extensions. –  Abhijit Navale May 27 '12 at 9:20
    
@Abhijit Have you tried going to extensions.gnome.org and reinstalling your extensions? –  AgentK May 27 '12 at 23:52
    
@Agentk Yes I tried reinstall it 2-3 times. What I found out was that, If I had this extension uninstalled then tweak tool runs fine. The moment I install it, the tweak tool again refuses to run. –  Abhijit Navale May 30 '12 at 6:58
    
@AbhijitNavale Excellent. Exactly what I was experiencing too until I ran the sudo cp command above. –  AgentK Jun 3 '12 at 2:16

protected by Community Oct 6 '12 at 8:11

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.