Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

On my Asus K53S i7, the F5 and F6 keys, for brightness controls, don't work. In Ubuntu 11.10 and in 12.04 (by upgrading mode).

I don't know if there is some relationship with the first problem, but when I change brightness values by menu, and restart notebook, the default values (100%) comes back again.

Is out there some solution for this problems?

share|improve this question
    
same pc , its working fine for me. –  BigSack Sep 27 '12 at 12:06
    
F5 and F6 are working in Ubuntu 12.04? Did you do anything? Did you install any proprietary drivers (I've no one)? –  R. Cardoso Sep 28 '12 at 10:48
    
No , its working fine since i installed this machine with Ubuntu 12.04 –  BigSack Sep 28 '12 at 14:20
    
What do you have in /etc/default/grub, in line GRUB_CMDLINE_LINUX_DEFAULT and GRUB_CMDLINE_LINUX? –  R. Cardoso Sep 28 '12 at 14:40

5 Answers 5

If your dmesg log (run this command to reveal) contains a multitude of lines that resemble the following:

[   21.290709] ACPI Error: Method parse/execution failed [\_SB_.PCI0.VGA_.LCDD._BCM] (Node ffff880138a3a578), AE_AML_BUFFER_LIMIT (20110623/psparse-536)
[   21.290718] ACPI Error: Evaluating _BCM failed (20110623/video-372)

open /etc/default/grub with root rights in an editor (gksu gedit /etc/default/grub) and change GRUB_CMDLINE_LINUX_DEFAULT to the following:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=\"!Windows 2009\""

Save, quit the editor and run:

sudo update-grub

Reboot and hopefully your brightness keys start working. This works on a range of Asus laptops, including my K70IJ.

share|improve this answer
    
Thank you #Cumulus007. But with 'dmesg | grep Error' I get no errors. Should I change grub file anyway? –  R. Cardoso Aug 26 '12 at 22:48
    
Well, I tried it. But F5+F6 keep not working. –  R. Cardoso Aug 27 '12 at 9:04
    
Try pressing the brightness keys and check dmesg for any messages that look related. –  Cumulus007 Aug 27 '12 at 10:07
    
I have tried with >> watch 'dmesg | tail -50' << but nothing is detected when using Fn keys (anyone)! –  R. Cardoso Aug 28 '12 at 16:21

I'm still waiting for the proper fix, but for now I use the following script as workaround:

echo "Enter bright value 1-10 (asus k53s)"
read input_var
sudo /usr/lib/gnome-settings-daemon/gsd-backlight-helper --set-brightness $input_var

Save it like bright.sh and do a chmod +x bright.sh to give it execute permission. Now execute the file and pick a value from 1 to 10 as required.

share|improve this answer
    
Thank you, #sainf. –  R. Cardoso Jun 26 '12 at 14:01
    
None of the answers solved my problem with the brightness keys. I tried a clean installation of the new Ubuntu 12.10 too, but the problem is still there. Using workaround scripts is not so practical as functions keys use. –  R. Cardoso Oct 22 '12 at 22:02

SOLVED, in a indirect way. Not doing Fn+F5 or Fn+F6, but F5 or F6 only... To do that, for F5, I created a script as:

#!/bin/bash
currentBrightness=`cat /sys/class/backlight/acpi_video0/actual_brightness`;
myBrightness=$currentBrightness - 1;
if [ $myBrightness < 1 ]; then
    myBrightness=1;
else
xdotool key XF86MonBrightnessDown;
fi`. 

With execution permission given to the script, with Ubuntu Tweak (Administration > Shortcuts) I binded the script to F5 key.

For F6 key, the script is:

#!/bin/bash
currentBrightness=`cat /sys/class/backlight/acpi_video0/actual_brightness`;
myBrightness=$currentBrightness + 1;
if [ $myBrightness > 10 ]; then
myBrightness=10;
else
xdotool key XF86MonBrightnessUp;
fi`

Another simple alternative is install Brightness Indicator. Instructions in: http://www.noobslab.com/2012/11/indicators-collection-for-ubuntu.html

share|improve this answer

I have the same problem on a Asus K53S. Out of the box the function keys, mouse scroll did not work. The video drivers was incorrect but the bumblebee driver fixed the problem. Same problem on 11.04. The volume keys work, but no brightness control.

share|improve this answer
1  
No solution for this? –  R. Cardoso Jun 4 '12 at 21:30
    
I installed Ubuntu 12.04 by upgrade mode, and a clean install of 12.10. The problem is in both. I tried to install nvidia drivers and bumblebee too. None of them have solved f5+f6 brightness keys. –  R. Cardoso Oct 22 '12 at 22:09

There is an alternative to change the brightness level. Use xbacklight. For example: xbacklight -set 0 will reduce it to the lowest brightness level of you display.

share|improve this answer
    
Thank you #Jay. But I pretend to work with Fn keys (F5+F6), if possible. –  R. Cardoso Aug 26 '12 at 22:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.