Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Help! I have upgraded from 11.10 to 12.04 but it doesn't pick up the keyboard so I cannot type in my login keyring password to do anything. I have tried a spare USB keyboard but this is not picked up either. Any if I put a USB stick in the menu comes up and I can open and edit a document - keyboard must work! Any ideas? I get an error message - cannot capture your keyboard so cannot get past 'Enter password to unlock your login keyring.'

share|improve this question

2 Answers 2

I have solved both keyboard and networking issues (keyboard not recognized and no network connection) by rolling back to kernel 3.0.0-15-generic-pae.

Just selected 3.0.0-15 in "Previous Linux Versions" section of GRUB menu.

If that works yuo couldalso uninstall newer kernel (sudo apt-get remove 3.2.0.24) and update GRUB (sudo update-grub).

Hope this helps.

share|improve this answer
    
Thank you. What Iam getting now is an error message - 'The application Compiz has closed unexpectedly.' The keyboard is now recognised but I just get the desktop background with no icons on it. I can't seem to get any up.How can i get to the GRUB menu? –  Nigel Lacey Apr 29 '12 at 10:58
    
to enter GRUB menu press shift during boot (just after bios screen). I even had to clean up my home directory from profile settigns but still got same error sometimes, but everything works ok. –  Eduard Apr 30 '12 at 8:21

I have a similar problem, and can get around it by clicking cancel on the keyring login. Not sure if that helps or not. Unity still not working for me though !!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.