Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Sorry if this question has been asked before; if it has, I couldn't find it.

On 12.04 I'm able to connect to wi-fi and load pages on the internet, but I'm asked to reenter the wi-fi password every ten seconds. If I reenter it, it connects again just fine, but it asks again in about ten seconds, making the wi-fi essentially unusable.

I use a Lenovo ThinkPad SL510, if that matters. I never had a similar problem under 11.10.

share|improve this question

marked as duplicate by Seth, Eliah Kagan, vasa1, Eric Carvalho, txwikinger Mar 21 '13 at 21:42

This question was marked as an exact duplicate of an existing question.

Welcome to Ask Ubuntu! We need more hardware information to help you, can you look at this question and then edit your question adding the information? – Jorge Castro Apr 28 '12 at 16:18
This question appears to be abandoned and unanswered, could you perhaps add more detail to your question? If this question no longer applies then you can either delete it or answer it yourself if you've solved the problem. This is to help with the Ask Ubuntu Clean Up. If you feel this question is not abandoned, please flag the question explaining that. :) – Seth Jan 7 '13 at 22:47

I had the exact same problem with my Dell XPS...I found this:

The solution at the above link basically takes you into the settings of the wireless connection, to a spot where you can enter the password and save it. It worked for me.

share|improve this answer

I recently got fed up with trying to fix wireless issues with my SL510. I could reset (sudo service network-manager restart) the network manager, or bring the wireless card down and up (sudo ifconfig wlan0 down && sudo ifconfig wlan0 up). When it didn't crash gnome, it worked well. I did a bit more exploring and found that my hardware an SL510 is verified on 11.04

You can look up other models and if they're certified against a specific release at the following.

I reinstalled 11.04 and only applied security related patches.

Some people reported luck and success by following this article form Unix Men.

Resolve slow connexion when using wifi in ubuntu 11.04, 11.10, 12.04 Precise Pangolin & LinuxMint12

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.