Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Using maverick ubuntu with added kubuntu-desktop:

I look at KDE systemsettings in the multimedia section. Under phonon backend it says I use xine. No option to add or change anything here.

Now gnome uses gstreamer and pulseaudio ...

I'm using a lot KDE applications in gnome and a lot of gnome applications with KDE. I use wine applications also. Therefore It seems reasonable to reduce the soundsystem to one framework. (?)

Should I use Xine or gstreamer? I read Kubuntu uses pulseaudio as well, but I can't find it in there,though I really like pulseaudio for the ability to manually tell the system toplay this apllication's sound on headphone, the other one on internal soundchip and so forth ...

What to do to have a running pulseaudio system for all occasions and what's the best way to play the sound of the applications with either xine or gstreamer?

share|improve this question

2 Answers 2

up vote 3 down vote accepted

If you use Kubuntu 10.10 (or Ubuntu 10.10 with kubuntu-desktop installed, as you seem to be), you are using the same backend. I.e., you're using ALSA as your sound drivers and low userspace, and you're using PulseAudio for your backend on top of the ALSA userspace. Xine-lib and GStreamer are both configured by default to use PulseAudio if available, so in your case, without doing anything you're using pulse already. (Note: currently work is being done for QtGStreamer, so at some point KDE will pick up that backend natively; thus Kubuntu will gain it, too.)

share|improve this answer
    
Thx Daniel! Does this mean I should set all apllications to use gstreamer instead of xine if that option is available to ensure the best compatibility for the future path of Kubuntu? –  piedro Dec 1 '10 at 15:44
    
You don't need to do anything. I've edited my answer above (italicized) to clarify that. –  Daniel T Chen Dec 1 '10 at 19:06
    
thx for clarifying –  piedro Dec 6 '10 at 13:51

You need to install phonon-backend-gstreamer Install phonon-backend-gstreamer to give Phonon the option to use GStreamer.

I'll leave it up to other people to answer your other questions, as I don't use KDE often enough to answer those...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.