Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Here's what the problem is.

About a day or so ago I used Gparted live cd to create 3 NTFS primary partitions on my external 500 gig Goflex and one extended with 2 logical partitiones.

I had planned to install windows 8 on the first partition, then ubuntu and kubuntu on the other 2.

After I finished partitioning my drive with gparted, I booted into windows vista to make my bootable windows 8 usb to install it with, I also decided to check to make sure all my partitions were working properly.

Then I found they were, and they weren't.

My 50 gig first partition I had planned to install windows on showed up normal and the 300 gigs of space left in the extended partition did as well, the rest showed up as raw.

So I figured alright, something went awal while making the partitions, so I booted up gparted once again.

Then to my surprise gparted showed the entire drive as unallocated, and when I refreshed the list, it showed as all the partitions I had made earlier, buy with a exclamation mark by them all.

So I figured ok, might be a problem with the partition table as I'd seen a similar problem in past on a drive that was not partitioned at all, so I decided to create a new partition table and take the time out again to sit and wait.

Then I got a message saying gparted could not create the partition table, followed by it showing the entire drive as formatted into ntfs.

After that I figured ok I'll take a break, come back in a hour, maybe it's something I did.

So a hour later I came back after having booted up windows, plugged the drive in to see if by some miracle windows could access the drive.

In disk management when I plugged the drive in, it would freeze attempting to read the drive, as I'd seen in the past with raw disks, yet when I unplugged it I got a glimpse of disk management showing it as a perfectly fine ntfs file system on the drive followed by a "you must format disk K in order to use it".

So I then was assured the disk was raw as that is what had happened in the past, followed by a new partition table through gparted to fix the problem and a 10 hour format in windows.

So I once again booted up gparted, to get the message "error fsyncing/closing/dev/sdg:input/output error" followed by "error opening dev/sdg No such file in directory" after I refreshed and somehow saw the disk show up as perfectly fine ntfs and then tried to create a new partition table to try to wipe out all my problems and start over again.

And not gparted only shows the drive there about 1/10 refreshes the rest I get the directory error.

If anybody can assist me in any way shape or form I will be thankful.

share|improve this question
1  
I am not sure but I think Windows can't recognize extended volumes properly. U should install Windows on primary partitions. –  Michael Tanner Apr 29 '12 at 21:14
    
Although you intend to eventually install Ubuntu, it seems to me this question isn't really about Ubuntu in any way. You're using a GNU/Linux distro--the GParted Live CD (which is not Ubuntu). And you're getting stuck on creating partitions that you can then see, especially in Windows. This question is probably off-topic for Ask Ubuntu. If you still need help, this would probably be more appropriate for Super User. –  Eliah Kagan Apr 10 '13 at 10:29

3 Answers 3

Windows 8 comes with a protected partition for security reasons. I believe it's called EUFI. You need to disable the protection in the BIOS (usually something like F2 or F11 at bootup.) This is the only thing you need to do in order to remove Windows 8 completely and install Ubuntu...

However, if you wish to dual boot, you need to be ready to work - because it's hard work. Take a look at this tutorial at intructables.com which I used to dual boot my newly bought laptop. I later on downgraded to Windows 7 by the way.

Good luck...

share|improve this answer

Maybe zeroing out the MBR could help? dd if=/dev/zero of=/dev/sdX bs=512 count=1. I don't know how to do it for a GPT disk. After that, you could try the command line way: create the partition table in parted and then create the partitions with mkfs -t type /dev/sdXn.

share|improve this answer

Why do you create so many NTFS partitions in the first place? As for your info, Ubuntu/Kubuntu can't be installed on one of those, they require a Linux file system like ext4.

I'd suggest the following:

  1. Delete all partition.

  2. Use Vista to create a primary NTFS partition for Windows8, and then proceed installing it.

  3. Install Ubuntu and Kubuntu. You can create partitions for them inside the installer.

share|improve this answer
1  
That's the thing, I have been attempting to delete the partitions and create a new partition table but I can't gparted can't even do it. –  William Apr 28 '12 at 16:24
    
Any particular reason to insist using Gparted? It doesn't seem to work very well for you. –  mikewhatever Apr 28 '12 at 16:30
    
It was working fine till now, any it's the only partitioning software that has worked well for me before. If you know of a better partitioning software, I'll try it out. –  William Apr 28 '12 at 16:35
    
Try using fdisk. It's command line but it's not that bad. It has a very detailed menu. –  ndefontenay Aug 15 '13 at 18:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.