Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Multi-touch works fine on Windows 7 with: two-fingers scroll vertical and horizontally, two-finger tap for middle click, and three-finger tap for right click.

However with Ubuntu, I've never been able to get multi-touch to "save" and work, I was able to get it to work a few times but after restarting - it would just reset back.

I have the settings for two-finger scrolling on:
Mouse and Touchpad > Touchpad

Two-finger scrolling (selected)
Enable horizontal scrolling (ticked)

The cursor stops moving when I try to scroll with two fingers, but it doesn't actually scroll the page.

When I perform xinput list, I get:

Virtual core pointer id=2 [master pointer (3)]
↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
↳ ETPS/2 Elantech ETF0401 id=13 [slave pointer (2)]

I've tried to install some 'synaptics-dkms' bug-fix (from a few years back) but that didn't work, so I removed that.

I've tried installing 'uTouch' but that didn't seem to do anything so removed it.

Here's what I have installed now:

dpkg --get-selections > installed-software
grep 'touch\|mouse\|track\|synapt' installed-software

libsoundtouch0 --- install
libutouch-evemu1 --- install
libutouch-frame1 --- install
libutouch-geis1 --- install
libutouch-grail1 --- install
printer-driver-ptouch --- install
ptouch-driver --- install
xserver-xorg-input-multitouch --- install
xserver-xorg-input-mouse --- install
xserver-xorg-input-vmmouse --- install
libnetfilter-conntrack3 --- install
libxatracker1 --- install
xserver-xorg-input-synaptics --- install

So, I'll start again, what should I do now to get two-finger scrolling to work and ensure it works after restarting?

Also doing:

synclient TapButton1=1 TapButton2=2 TapButton3=3

...works but doesn't save after restarting.
However doing:

synclient VertTwoFingerScroll=1 HorizTwoFingerScroll=1

Does NOT work to fix the two-finger scrolling.

Output of: cat /var/log/Xorg.0.log | grep -i synaptics

[ 4.576] (II) LoadModule: "synaptics"
[ 4.577] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
[ 4.577] (II) Module synaptics: vendor="X.Org Foundation"
[ 4.577] (II) Using input driver 'synaptics' for 'ETPS/2 Elantech ETF0401'
[ 4.577] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
[ 4.584] (--) synaptics: ETPS/2 Elantech ETF0401: x-axis range 0 - 1088
[ 4.584] (--) synaptics: ETPS/2 Elantech ETF0401: y-axis range 0 - 704
[ 4.584] (--) synaptics: ETPS/2 Elantech ETF0401: pressure range 0 - 255
[ 4.584] (--) synaptics: ETPS/2 Elantech ETF0401: finger width range 0 - 16
[ 4.584] (--) synaptics: ETPS/2 Elantech ETF0401: buttons: left right middle double triple scroll-buttons
[ 4.584] (--) synaptics: ETPS/2 Elantech ETF0401: Vendor 0x2 Product 0xe
[ 4.584] (--) synaptics: ETPS/2 Elantech ETF0401: touchpad found
[ 4.588] (**) synaptics: ETPS/2 Elantech ETF0401: (accel) MinSpeed is now constant deceleration 2.5
[ 4.588] (**) synaptics: ETPS/2 Elantech ETF0401: MaxSpeed is now 1.75
[ 4.588] (**) synaptics: ETPS/2 Elantech ETF0401: AccelFactor is now 0.154
[ 4.589] (--) synaptics: ETPS/2 Elantech ETF0401: touchpad found

Tried installing synaptiks but that didn't seem to work either, so removed it.

Temporary Fix (works until I restart)

Doing the following commands:

modprobe -r psmouse
modprobe psmouse proto=imps

Works but now xinput list shows up as:

Virtual core pointer id=2 [master pointer (3)]
↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
↳ ImPS/2 Generic Wheel Mouse id=13 [slave pointer (2)]

Instead of Elantech, and it gets reset when I reboot.

Solution (not ideal for most people)

So, I ended up reinstalling a fresh 12.04 after indirectly playing around with burg and plymouth then removing plymouth which removed 50+ packages (I saw the warnings but was way too tired and assumed I could just 'reinstall' them all after (except that didn't work).

Right now xinput list shows up as:

⎡ Virtual core pointer --- id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer --- id=4 [slave pointer (2)]
⎜ ↳ ETPS/2 Elantech Touchpad --- id=13 [slave pointer (2)]

grep 'touch\|mouse\|track\|synapt' installed-software

libnetfilter-conntrack3 --- install
libsoundtouch0 --- install
libutouch-evemu1 --- install
libutouch-frame1 --- install
libutouch-geis1 --- install
libutouch-grail1 --- install
libxatracker1 --- install
mousetweaks --- install
printer-driver-ptouch --- install
xserver-xorg-input-mouse --- install
xserver-xorg-input-synaptics --- install
xserver-xorg-input-vmmouse --- install

cat /var/log/Xorg.0.log | grep -i synaptics

[ 4.890] (II) LoadModule: "synaptics"
[ 4.891] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
[ 4.892] (II) Module synaptics: vendor="X.Org Foundation"
[ 4.892] (II) Using input driver 'synaptics' for 'ETPS/2 Elantech Touchpad'
[ 4.892] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
[ 4.956] (II) synaptics: ETPS/2 Elantech Touchpad: ignoring touch events for semi-multitouch device
[ 4.956] (--) synaptics: ETPS/2 Elantech Touchpad: x-axis range 0 - 1088
[ 4.956] (--) synaptics: ETPS/2 Elantech Touchpad: y-axis range 0 - 704
[ 4.956] (--) synaptics: ETPS/2 Elantech Touchpad: pressure range 0 - 255
[ 4.956] (--) synaptics: ETPS/2 Elantech Touchpad: finger width range 0 - 15
[ 4.956] (--) synaptics: ETPS/2 Elantech Touchpad: buttons: left right double triple
[ 4.956] (--) synaptics: ETPS/2 Elantech Touchpad: Vendor 0x2 Product 0xe
[ 4.956] (--) synaptics: ETPS/2 Elantech Touchpad: touchpad found
[ 4.980] () synaptics: ETPS/2 Elantech Touchpad: (accel) MinSpeed is now constant deceleration 2.5
[ 4.980] (
) synaptics: ETPS/2 Elantech Touchpad: MaxSpeed is now 1.75
[ 4.980] (**) synaptics: ETPS/2 Elantech Touchpad: AccelFactor is now 0.154
[ 4.980] (--) synaptics: ETPS/2 Elantech Touchpad: touchpad found

So, if all else fails, reinstall Linux :/

share|improve this question
    
Type cat /var/log/Xorg.0.log | grep -i synaptics into the Terminal. What do you get? –  Chan-Ho Suh Apr 28 '12 at 21:47
    
Added output of command to question above –  dan2k3k4 Apr 28 '12 at 23:20
1  
@Dan2k3k4 your temporary solution worked for me as well. See my post if you want the changes to last after reboot askubuntu.com/a/127761/57842. –  garnertb Apr 29 '12 at 13:33
    
I 'indirectly' reinstalled 12.04 which seems to have fixed my problem, now I just need to get the synclient settings to 'save' –  dan2k3k4 Apr 29 '12 at 16:57

4 Answers 4

To get your synclient settings to stick you can add them to xorg.conf. I did this recently for my macbook pro in 12.10 and it works pretty well.

You can also specify a separate configuration file in /etc/X11/xorg.conf.d/ file to keep things neater. Here's a step by step:

  1. Create /etc/X11/xorg.conf.d (if it doesn't already exist)

    sudo mkdir /etc/X11/xorg.conf.d

  2. Create and edit /etc/X11/xorg.conf.d/10-synaptics.conf

    gksudo gedit /etc/X11/xorg.conf.d/10-synaptics.conf

  3. Make it look like the following:

    #Sample /etc/X11/xorg.conf.d/10-synaptics.conf
    Section "InputClass"
      Identifier "touchpad catchall"
      Driver "synaptics"
      MatchDevicePath "/dev/input/event*"
      MatchIsTouchpad "true"
      Option  "SHMConfig"           "true"
      Option  "TapButton1"          "1"
      Option  "TapButton2"          "2"
      Option  "TapButton3"          "3"
    EndSection
    
  4. Save and logout/login again. If the xserver fails to load and you get forced into low graphics mode then edit the file again and comment everything out, or mv /etc/X11/xorg.conf.d/10-synaptics.conf ~/10-synaptics.conf.backup and reload again to get back to normal.

For posterity, my current setup for my macbook pro 2012 13" is as follows (warning, I like my touchpad rather sensitive). Try any of these options using synclient before putting them into xorg.conf!

Section "InputClass"
      Identifier "touchpad catchall"
      Driver "synaptics"
      MatchIsTouchpad "on"
      MatchDevicePath "/dev/input/event*"
      MatchProduct "bcm5974"
      MatchIsTouchpad "true"
      Option  "SHMConfig"           "true"
      Option  "FastTaps"            "1"
      Option  "MaxDoubleTapTime"    "100"
      Option  "BottomEdge"          "6000"
      Option  "FingerLow"           "60"
      Option  "FingerHigh"          "90"
      Option         "ClickFinger3" "2"
#      Option         "FingerLow"             "30"
#      Option         "FingerHigh"            "80"
      Option         "VertTwoFingerScroll" "1"
      Option         "HorizTwoFingerScroll" "1"
      Option         "VertScrollDelta" "100"
      Option         "HorizScrollDelta" "100"
      Option         "MultiFingerButton" "2"
      #Option         "TapButton1" "1"
      Option         "TapButton2" "3"
      Option         "TapButton3" "2"
      Option         "MinSpeed" "1"
      Option         "MaxSpeed" "2"
      Option         "AccelFactor" "0.01"
#      Option         "AreaBottomEdge" "5000"
EndSection
share|improve this answer

Here's what I do.

Write up a shell script, mine is called "synScript.sh", the name doesn't matter. Mine contains:

    synclient MaxTapTime=0

I saved it under the folder ~/Scripts (which I created). Make sure you right click it after you save it and go to permissions to enable the file to be executed. Then edit your lightdm.conf:

    sudo nano /etc/lightdm/lightdm.conf

Add this line to the bottom of lightdm.conf

    display-setup-script=/home/[your username]/Scripts/synScript.sh

Now the script will always run before lightDM, so this way, even if you use different DEs (i.e. Xmonad) you'll have the same touchpad settings throughout. By the way, if you need to know what settings to change just ctrl+alt+t to a terminal and type:

    synclient

to see what your defaults are.

Slainte!


.pc

share|improve this answer

have you tried synaptics from either the package manager or the software center (don't remember where its at).

EDIT

Try this link --- https://bugzilla.redhat.com/show_bug.cgi?id=728607 --- there's a patch that might fix it. I had to get a patch before for 11.10. Then used synaptiks (sorry for mispell). look through the thread for the latest v.

share|improve this answer
1  
doesn't seem to work either :( –  dan2k3k4 Apr 28 '12 at 23:54
    
I didn't actually find a way to download and test the patch you linked to (it seems like I would have had to compile the kernel? or similar?), but I've 'indirectly' solved my question by reinstalling 12.04 –  dan2k3k4 Apr 29 '12 at 16:58

The new update in Debian Wheezy solves the two finger scrolling problem for me on Asus EEE 1000. I presume it will filter through to Ubuntu shortly.

xserver-xorg-input-synaptics v1.5.99.904.1

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.