Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 12.04 today on my Samsung RV509 Notebook (Nvidia Geforce 315M) and the backlight brightness controls don't work on it.

I did some digging around the web and found the samsung tools voria repository and installed Samsung-backlight package from there. This didn't help though.

I see that the Nvidia drivers are in use. Any help or pointers are appreciated.

share|improve this question
    
I just figured out that I can decrease brightness from the nvidia X server setting panel directly. Ubuntu is still unable to directly decrease the brightness from system settings though. –  Nands Apr 28 '12 at 18:56
    
Ok, I got a bit confused between brightness and backlight. The nvidia setting decreases the brightness of the images,vidoes ect, so they start looking dull and undefined. What I'm looking for reducing backlight intensity. –  Nands Apr 29 '12 at 14:41
    
possible duplicate: askubuntu.com/q/76081/43660 –  Chan-Ho Suh May 31 '12 at 5:37
add comment

3 Answers 3

Run:

gksu gedit /etc/X11/xorg.conf

Add

Option "RegistryDwords" "EnableBrightnessControl=1"

to the “Device” section so it looks somewhat like this:

Section "Device"
Identifier  "Default Device"
Option  "NoLogo"    "True"
Option "RegistryDwords" "EnableBrightnessControl=1"
EndSection

Then restart the X server.

share|improve this answer
    
You may want to edit your post to include information about how to restart the X server. Also, please note that, as discussed in comments to this question, backlight intensity and brightness are two different things. –  Eliah Kagan Jun 3 '12 at 6:54
add comment

You may try this:

gksudo gedit /etc/default/grub

Find this line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

And change to:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

Save and close the file. Then update grub:

sudo update-grub

Reboot and check.

This did the trick for me on a Samsung NP300 notebook. The brightness keys in the keyboard were not working before this. Hope this helps.

share|improve this answer
    
Thanks. I made this change. Now when I unplug the power the backlight decreases automatically. Bad part, the hot keys (Fn keys) do not work anymore. I have not way left to change the backlight manually. I do not care much about the Fn keys but I want a way to change backlight manually whenever I want. –  Nands Apr 30 '12 at 10:22
add comment

I suggest that you use Ubuntu 11.10. And install all the available drivers from the Voria repo. Make sure you have nvidia_bl installed which is required to correctly manage brightness.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.