Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I upgraded to 12.04 all the 32bit libraries was removed. When I used Synaptic to upgrade, Synaptic installed all the 32bit libraries. When I later used apt-get to install a ppa, I was told to use autoremove to remove all the 32bit libraries, which I did.

After this Synaptic wanted to install the libraries again, but now I marked ia32-libs forinstead. The installation works fine, but I am not able to install Skype as Skype depeneds on ia32-libs.

When I try to install ia32-libs, I get this error printout

ia32-libs: Depends: ia32-libs-multiarch

share|improve this question
    
That would be a big problem also for running Wolfram research CDF player on Linux. Since ia32-libs are needed to run the player! –  Nasser Apr 28 '12 at 12:48
1  
I don't use Skype, but can you try installing the 32 bit package of Skype? I also uninstalled ia32-libs, so I could not install the 64 bit version of Google Earth, but the 32 bit package worked. –  elmicha May 1 '12 at 12:56

3 Answers 3

I had the same problem. This worked for me:

sudo apt-get purge ia32-libs
sudo apt-get install librtmp0/precise
sudo apt-get install ia32-libs
share|improve this answer

Have you tried installing ia32-libs-multiarch Install ia32-libs-multiarch? If you get any more dependency issues, install those as well.

share|improve this answer
    
That was the first I thought of, but when I look in Synaptic there is no ia32-libs-multiarch available. I also tried to download and install ia32-libs-multiarch, but that did not work either. However I just found a solution in the archived Precise development forum. Skype works if you install the 32-bit version instead of the 64-bit version on a 64-bit installation of 12.04 –  P-I H Apr 28 '12 at 20:05
    
Ah cool, thanks for the info! –  Rumbles May 1 '12 at 10:44

It's likely that those packages are missing on the mirror that you are using.

You could consider switching to a different mirror which hopefully has a more up to date package list.

share|improve this answer
    
Why would some Ubuntu mirrors not have these packages? –  Eliah Kagan Oct 28 '12 at 16:33
    
It's possible that a non-default mirror didn't sync entirely with the main server which is being used. –  Carroarmato0 Oct 28 '12 at 20:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.