Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Possible Duplicate:
What are Unity’s keyboard and mouse shortcuts?

What are the keyboard shortcuts to minimize, maximize, and close windows on Ubuntu 12.04 using Unity?

Alt-F4 to close the window
Ctrl-Super-Up to maximize window
Ctrl-Super-Down to unmaximize window
Ctrl-Alt-0 to minimize window - Does not work for some reason
share|improve this question

marked as duplicate by Jorge Castro, maythux, jokerdino, Tom Brossman, Eliah Kagan Oct 11 '12 at 10:58

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

related question ->… – hhlp Apr 28 '12 at 12:14
Try Ctl-Alt-Numpad0. – Flimm Sep 18 '13 at 14:20
up vote 2 down vote accepted

Press Alt + Space (open window context menu) and then use accelerator key (underlined) for your desired option.

Update: Also, in Unity (no unity 2D I think), you can hold Win key and it shows you some help.

share|improve this answer
Thanks. All those worked, except Ctrl-Alt-0, which is supposed to minimise, but it does nothing when I try it... – oshirowanen Apr 28 '12 at 12:15
did you do ctrl+alt+Numpad0? Only the numpad 0 works for this shortcut. – amc May 25 '12 at 2:37

Install compiz configuration manager. Then go to General Options; Key Bindings and you can set the key bindings to perform the actions you need.

share|improve this answer
Compiz manager works for Unity2D? – oshirowanen Apr 28 '12 at 12:04
yes, but handle with care! may break your glassy unity – Prasad RD Apr 28 '12 at 13:46

Long press super(windows) key to get on-screen hint. According to that, no shortcut for minimize window. super+up = maxmize windows

share|improve this answer

FWIW I was able to get ctrl+alt+0 to work by going to keyboard settings and remapping it to the same Ctrl+Alt+0 combination.

Although the help that shows up when you long press the super key says that Ctrl+Super+Down should also minimize and not just restore. It doesn't work for me however.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.