Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to change Key short cut to Super+L for LockScreen but it is not working. If I try any other combination like CTRL+ALT+L or CTRL+ALT+G , it works. Win+L combination used to work in 11.10.

enter image description here

share|improve this question
    
Have same problem and it's damn annoying :/ –  canni May 8 '12 at 9:35
    
Anybody else have Win/Super + l make their display settings reverted to a previous setting? I used the System Settings to rotate my display and I noticed that pressing Win+L will flip flop it between normal rotation and the 90degree rotation. –  user29020 2 days ago

2 Answers 2

This is a confirmed bug #951805 in Ubuntu since 12.04 beta 1 stage. Unfortunately no solution is available as of yet, but everyone being affected by this bug can sign in to Launchpad and subscribe to the bug report for future updates.

share|improve this answer

Yes, it's very annoying, and hard to remember the exact fix. So hopefully this will help you, and also be an easy way for me to look this up next time I do a fresh Ubuntu install.

There is duplication & conflict between the Gnome Keyboard Shortcut settings (as depicted in your screen shot) and the same settings in the new Unity desktop. Ubuntu (well, Gnome) provides a UI for editing the Gnome Keyboard Shortcut settings but as you've learned, they don't work if they conflict with Unity. And there is no UI installed by default for managing Unity.

Note that to get 'Super-X' style shortcuts to work, you will have to change the 'key to show the launcher' setting, which means that the Super/Windows key will no longer open the launcher. If that's OK with you, continue...

Here is what I do:

  1. Install compizconfig-settings-manager (some will warn you not to, because it gives you enough power to really mess things up). There may be a way to change these without using CCSM but if so, I don't know it. Install it via the Ubuntu Software Center, or:

    $ sudo apt-get install compizconfig-settings-manager

  2. Run CompizConfig Settings Manager; acknowledge the warning message.

  3. Locate and click the Ubuntu Unity Plugin icon in the Desktop section
  4. Change the Key to show the launcher (on the Behaviour tab). To do this:
    • Click the button which says <Super>
    • Click Grab key combination
    • Press a new key or key combination (this will, from now on, open the Unity launcher); I use <Alt>-<Super>

CompizConfig Settings Manager - changing launcher key

The <Super>-L 'Lock Screen' combination that you already set up should now just work!

Bonus

Note that CCSM also provides its own facility for setting keyboard shortcuts. For things not included in the gnome-control-center, you may have more luck defining custom shortcuts in CCSM. If you select Commands from the General section in CCSM, you can define custom commands, like I've done here: CompizConfig Settings Manager - Commands editor

...and then, you can associate those commands with specific key combinations, like this: CompizConfig Settings Manager - Key bindings

As you can see, I've configured Super-E to launch the Gnome text editor, and Super-C to launch the calculator. I find both of these very handy.

share|improve this answer
    
NB: The screenshots are a little different for 13.10 but this method still works. Note that /usr/bin/gcalctool doesn't exist in 13.10; it's /usr/bin/gnome-calculator –  Eric Lambart Mar 12 at 19:24
    
Looks like 14.04 has Super-L preconfigured to lock the screen, among other more convenient shortcuts. However, I still had to install CCSM and reconfigure what's now called the "Key to show the Dash, Launcher and Help Overlay", in order to configure Super-T for anything besides the hard-coded but rather useless (to me) Trash browser. –  Eric Lambart Jun 23 at 21:57
    
Looks like unity-tweak tool will do the trick; no need to install ccsm. sudo apt-get install unity-tweak-tool and then run it. Under Unity->Additional, and change the 'Show the Launcher' setting. –  Eric Lambart Jun 24 at 18:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.