Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Since the 12.04 upgrade, each time I save within eclipse, I get that error :

An internal error occurred during: "Updating Change Sets for SVN Workspace". Selected SVN connector library is not available or cannot be loaded.

Subversion and libsvn-java are installed

My eclipse.ini holds the java.library.path arg :

-Djava.library.path=/usr/lib/jni

But there is no /usr/lib/jni directory...

In Pref > Team > SVN > SVN Connector, I have :

Cannot load libraries: Could not init class org.tigris.subversion.javahl.svnclient

Any idea ?

Edit

The path for 32 bits is /usr/lib/i386-linux-gnu/jni

share|improve this question
add comment

1 Answer

up vote 6 down vote accepted

In ubuntu 12.04 precise pangoline the directory for java.library.path has changed. I'set "-Djava.library.path=/usr/lib/x86_64-linux-gnu/jni" (on 64 bit installation) in eclipse.ini and i had no more problem

share|improve this answer
    
@Mordred: The splash complaining "javaHL library not found" is not showing anymore. I'm working with Spring STS 2.9.2 (based on eclipse 3.7.2) and subclipse 1.6.x. Are you shure that you not installed the 1.7.x version of sublicpse? In this case you have to downgrade to 1.6.x or to upgrade your subversion OS packages (included javaHL library) –  ivavis Apr 29 '12 at 15:35
    
Thanks a lot. The path for 32 bit ubuntu is /usr/lib/i386-linux-gnu/jni –  Sylvain Artois Apr 29 '12 at 21:38
1  
The 64 bit path is still failing on my 64bit Ubuntu 12.04. The JavaHL libraries are there, but the error message still occurs with subclipse 1.8 (not with 1.6). –  HDave Aug 31 '12 at 4:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.