Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
I can't boot into a usable system anymore. What should I do?

Was running 11.10, but decided to upgrade to 12.04. After more than 12 hours, my Dell Inspiron 15R was,just hanging. Could not do anything. So tried to reboot, all I get now is flashing screen on boot, but nothing more. Tried hitting shift before ubuntu loads & then the 1st option but all I get is a purple screen. So tried recovery & can get to a prompt, but how to I now 'recover' so that I can boot (load grub)?

I managed to get it all up & running after remounting / as rw, then setting up my network and finally running dpkg --configure -a.

share|improve this question

marked as duplicate by fossfreedom May 22 '12 at 18:26

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

3 Answers 3

I think this will help you.Please run an ubuntu live cd/usb and back up all your data first. A clean install is better than a painful upgrade.Do all your tweaks to recover the failed ubuntu feeling free as your data is safe.I dont know how to recover through a command prompt.U can update the grub from the live cd/usb too.

share|improve this answer

try to reinstall the grub loader. Use a live cd to get to terminal and use following code to mount your boot directory and reinstall grub loader

> mount /dev/your_boot_partiton /boot 
>grub-install --root-directory /boot /dev/hda

This will reinstall your grub. If you come up with an unsuccessfull attempt then I will recommend you to rienstall the Ubuntu

share|improve this answer

Try to check you permitions to /tmp folder. (After update, root folder because avaliable only for root)

This helped for me Ctrl + Alt + F1 then login and then $ sudo chmod 0777 -R /tmp

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.