Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am currently using two monitors with one in landscape mode and the other in portrait mode. Video card is Nvidia Geforce 9600 GT with nvidia's propriety driver.

I was able to force the issue in 11.10 by assigning a separate X screen for each monitor and rotating the screen assigned to the portrait monitor. ( :0 for the landscape and :1 for the portrait)

I heard that 12.04 improved greatly on multi-monitor configurations. But it doesn't work for me: I had to resort to TwinView mode in order to take advantage of seamless multi-monitor experience but TwinView mode doesn't work with my situation where one of the monitor is in portrait mode!

Even worse, when I go back to my original configuration, i.e. separate X screens instead of TwinView, my portrait monitor shows only white screen with default X cursor without any of unity goodness.

Anyone familiar with situation similar to mine?

share|improve this question
add comment

5 Answers 5

EDIT the post above:

I managed to solve the problem, but not for 3D because compiz crashes. here is the new xorg.conf:

    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings:  version 295.33  (buildd@zirconium)  Fri Mar 30 13:43:34 UTC 2012

    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        Screen      1  "Screen1" RightOf "Screen0"
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
        Option         "Xinerama" "1"
    EndSection

    Section "Files"
    EndSection
  Section "InputDevice"
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection

    Section "InputDevice"
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection

    Section "Monitor"
        # HorizSync source: edid, VertRefresh source: edid
        Identifier     "Monitor1"
        VendorName     "Unknown"
        ModelName      "DELL P2311H"
        HorizSync       30.0 - 83.0
        VertRefresh     56.0 - 76.0
        Option         "DPMS"
    EndSection

    Section "Monitor"
        # HorizSync source: edid, VertRefresh source: edid
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "DELL P2311H"
        HorizSync       30.0 - 83.0
        VertRefresh     56.0 - 76.0
        Option         "DPMS"
    EndSection

    Section "Device"
        Identifier     "Device1"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 8500 GT"
        BusID          "PCI:1:0:0"
        Screen          1
    EndSection

    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 8500 GT"
        BusID          "PCI:1:0:0"
        Screen          0
    EndSection

    Section "Screen"
        Identifier     "Screen1"
        Device         "Device1"
        Monitor        "Monitor1"
        DefaultDepth    24
        Option         "TwinView" "0"
        Option         "metamodes" "DFP: nvidia-auto-select +0+0"
        Option     "Rotate" "left"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection

    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "TwinView" "0"
        Option         "TwinViewXineramaInfoOrder" "CRT-1"
        Option         "metamodes" "CRT: nvidia-auto-select +0+0"
        Option     "Rotate" "left"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection

    Section "Extensions"
        Option         "Composite" "Disable"
    EndSection

I generated it using nvidia settings, not with twin view but with seperated X screens, screen 1 is absolute and screen 2 is Right Of. I checked Xinerama enabled. Then I edited the xorg.conf file so that to add option for rotation of both screens (look at the file). It worked!

share|improve this answer
add comment

Finally solved it myself.

Problem: Nvidia proprietary driver is no good with multiple monitors.

Solution: Switch to Nouveau open-source driver. Now it works flawlessly. Can configure either monitor in whatever configuration I want in Display settings.

share|improve this answer
    
It is possible to rotate 1 screen with the nvidia driver but a pain. every driver update you have to fiddle with it again –  Kendrick Dec 12 '12 at 2:45
add comment

I have a similar problem: I have been using until today ubuntu 10.4, I did not bother upgrading it since it worked and I need a working station in my office. It work under strange configuration: I used xinerama in the xorg.conf file (find it in /etc/X11/) and rotated the screens with the options given by the nvidia driver

Option "Rotate" "left"

It worked, I wrote it long time ago. Now, I wanted to try ubuntu 3D or Gnome 3D, but it dones not work, maybe because xinerama does not work with thi nvidia driver and the 12.04 release. It DOES work with ubuntu 12.04 if you choose 'gnome classic', but not otherwise. I tried to tweek with nvidia-settings program, but did not find any option to rotate the screens there.

here is the xorg.conf:

Section "Screen"
    Identifier     "Main"
    Device         "nvidia A"
    Monitor        "Dell-VGA"
    Option         "RenderAccel" "true"
    Option         "AllowGLXWithComposite" "true"
    Option         "AddARGBGLXVisuals" "true"
    Option         "Rotate" "left"
    DefaultDepth    24
    SubSection "Display"
        Depth       24
        Modes      "2160x1900@60" "2100x1600@60" "1536x1280@60" "1200x800@60" "1800x1440@60"
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Second"
    Device         "nvidia B"
    Monitor        "Dell-DVI"
    DefaultDepth    24
    Option         "RenderAccel" "true"
    Option         "AllowGLXWithComposite" "true"
    Option         "AddARGBGLXVisuals" "true"
    Option         "Rotate" "left"
    SubSection "Display"
        Depth       24
        Modes      "2160x1900@60" "2100x1600@60" "1536x1280@60" "1200x800@60" "1800x1440@60"
    EndSubSection
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

# commented out by update-manager, HAL is now used
#Section "InputDevice"
#   Identifier     "Keyboard0"
#   Driver         "keyboard"
#EndSection

# commented out by update-manager, HAL is now used
#Section "InputDevice"
#   Identifier     "Mouse0"
#   Driver         "mouse"
#   Option         "Protocol" "auto"
#   Option         "Device" "/dev/psaux"
#   Option         "Emulate3Buttons" "no"
#   Option         "ZAxisMapping" "4 5"
#EndSection

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen      0  "Main" 0 0
    Screen      1  "Second" RightOf "Main"
# commented out by update-manager, HAL is now used
#   InputDevice    "Keyboard0" "CoreKeyboard"
# commented out by update-manager, HAL is now used
#   InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "true"
EndSection

Section "Device"
    Identifier     "nvidia A"
    BoardName      "nv"
    BusID          "PCI:01:00:0"
    Screen          0
    Driver  "nvidia"
    Option  "NoLogo"    "True"
EndSection

Section "Device"
    Identifier     "nvidia B"
    BoardName      "nv"
    BusID          "PCI:01:00:0"
    Screen          1
    Driver  "nvidia"
    Option  "NoLogo"    "True"
EndSection

Again, I get dual screens, rotated properly with this conf file, but only on gnome classic login, not unity or 3D.

share|improve this answer
add comment

LAST EDIT:::

I finally got it... an ugly hack, but working perfectly!!!

Forgen xinerama! choose Twin View. Choose the left screen to be primary (absolute). the other one ABOVE the primary. then save the xorg file. edit it

sudo nano \etc\X11\xorg.conf

and add the rotation option to the screen Section. (Rotate left in my case). Then I got a perfect dual screen with two monitors, rotated, beside each other..... :-) Works only in unity, but not 3D. compiz is broken for now. N

share|improve this answer
add comment

I vote to post about Nouveau open source driver. I had the problem with 2 monitors in Ubuntu 12.04 LTS with NVidia proprietary driver. The answer really helped. I installed synaptic, launched synaptic, found all that concerned nouveau and added those packages. After that two monitors started to work properly. And I managed them from Display settings in System parameters.

share|improve this answer
    
I wish to add for any new people, you must remove the NVidia drivers first, reboot, install the Nouveau driver packages then reboot again and it will work. –  user74163 Jun 30 '12 at 6:01
add comment

protected by Community Jun 30 '12 at 13:46

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.