Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

when I enable the 'Place Windows' in the compizconfig settings editor in 12.04 (gnome-classic), windows which are placed over the border of the windows are moved back to the window as soon as the window loses focus. I often like to have windows being only half-way visible.

On the other hand, disabling the 'Place Windows' option will put newly created windows in position 0x0, which unfortunately is behind the panel.

How can I have smart placing of new windows, but not over existing windows?

share|improve this question
add comment

1 Answer 1

'Place Windows' seems to be pretty buggy--when I had it on, it would make my windows jump to a screen-edge whenever they lost focus (or, with terminal windows, sometimes when I just hit return to the command line, which seems completely bizarre to me).

But with 'Place Windows' off, the start-at-0,0 issue is made worse when you have dual-monitors, with the one on the left below the one on the right; in that case, the 0,0 point is not actually on any monitor, so depending on the window size it might not appear at all.

If the window is visible, you can do a ALT-leftmousebutton on the window and drag it to where you want it. If you have dual monitors, you probably want to ensure that the left one is positioned at least as high as the right one.

That was my solution--turn off 'Place Windows', redefine my left monitor position to be as high as my right, and just manually place all my windows. I don't need to use the ALT-left thing because my panels are on my right monitor so I just grab the title bar.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.