Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm pretty new to Linux and I'm trying to install Ubuntu 12.04 on my personal laptop, a Dell XPS 15. It has an NVIDIA GT540M with Optimus. Conveniently, there's no way to disable Optimus in the BIOS. lspci output:

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 540M] (rev a1)

I have bumblebee installed and it seems to work fine. I've been using glxgears from mesa-utils to test it. I'm not sure if this is normal, but running "glxgears" by itself gives:

Error: couldn't get an RGB, Double-buffered visual

But "optirun glxgears" works fine, getting framerates around 5800-6000 in 5 seconds.

My only issue is that the hardware-accelerated desktop effects aren't working. I can't enable wobbly windows or any animations. Worst of all, the Aero-like window-maximizing effect doesn't work. I haven't been able to get that effect enabled at all, even though it worked when I ran off the USB drive. I'm only assuming it's linked to my video card issues, but if there's a way to enable it please let me know!

Is it that optirun uses the NVIDIA drivers, but the intel drivers aren't setup properly? Did I miss a step?

Here's one more screenshot. It's also worth noting this is a 64 bit install of Ubuntu!

Another one I thought would be useful.

share|improve this question
    
Ok which bublebee have you installed? is it from MrMee repository (ironhide and bumblebee project) OR the bumble project (bumblebee-project.org)? –  Web-E Apr 28 '12 at 7:46
    
The bumblebee project. I updated the post with a screenshot if that helps. –  Jacob Ensor Apr 28 '12 at 17:36
add comment

2 Answers

up vote 3 down vote accepted

If you use nvidia-current-updates, you have to edit /etc/bumblebee/bumblebee.conf and set KernelDriver=nvidia-current-updates under [driver-nvidia].

It sounds that you've just installed Bumblebee, but that you've selected the universe repository during installation. That pulled in the nvidia driver which broke your 3D acceleration and other OpenGL capabilities. Try restarting the X server, e.g. by rebooting the machine.

In case the issue still persists, it is possible that some libraries have been installed in a wrong location. After installation of Bumblebee, /usr/lib/xorg/modules/extensions/ should not contain libglx.so, libglx.so.VERSION or nvidia_drv.so. If that is the case, remove those files (it requires root privileges):

sudo rm -f /usr/lib/xorg/modules/extensions/libglx.so* /usr/lib/xorg/modules/extensions/nvidia_drv.so

You may also have to reinstall the nvidia-current package if Bumblebee does not work afterwards:

sudo apt-get install --reinstall nvidia-current

Re-login and your problem should be solved.

share|improve this answer
    
I tried this to no avail. I'm more interested in the [driver-nouveau] section, actually. I know bumblebee works by creating a display :8 ran by the nvidia driver, and it seems to be working fine. It's the driver on the other display that I'm having problems with. Is that controlled by [driver-nouveau]? It seems like optimus runs my nvidia drivers fine, but my integrated intel card must not be letting hardware accelerated effects happen. –  Jacob Ensor Apr 28 '12 at 18:10
    
@JacobEnsor [driver-nouveau] is used if Driver=nouveau is set in [bumblebeed]. It has nothing to do with the primary X server that is run on the Intel graphics card. If you do not install nvidia drivers, 3D acceleration and such won't be broken. If possible, please paste your /var/log/Xorg.0.log file. –  Lekensteyn Apr 28 '12 at 19:54
    
paste.ubuntu.com/953725 –  Jacob Ensor Apr 28 '12 at 22:26
    
I see /usr/lib/x86_64-linux-gnu/xorg/extra-modules/libglx.so: libnvidia-tls.so.295.40: cannot open shared object file: No such file or directory. This indicated that an error occurred setting the so-called alternatives link of "...gl_conf". Try reinstalling bumblebee. If after rebooting/restarting X the issue still persists, please add the output of update-alternatives --display x86_64-linux-gnu_gl_conf to your question. –  Lekensteyn Apr 29 '12 at 8:36
    
paste.ubuntu.com/955156 I'm taking a look myself... I'm wondering if a solution similar to user corp769's at this link is in order... linuxquestions.org/questions/slackware-14/… –  Jacob Ensor Apr 29 '12 at 15:13
show 16 more comments

i faced the same problem.... i fixed it by reinstalling compiz-core package.. also please use "bumblebee tumbleweed 3.0".. its way better than ironhide.

share|improve this answer
    
Can you expand this answer to provide more information about exactly how to do that? –  Eliah Kagan Sep 8 '12 at 10:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.