Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After upgrading to 12.04, my system became terribly slow. Applications are running very slowly and become very unresponsive. I am not able to do anything. Before upgrading, it was running very good, even better than Windows.

I also often get errors when I try to run an application

What should I do? I want to make my Ubuntu work faster again. Please help me.

share|improve this question
Please add more detail to your question to enable people to help you. What errors are appearing when you run applications? Try running top from a terminal to see if you can see what's high on cpu usage. – 23 93 26 35 19 57 3 89 Apr 28 '12 at 7:05
As suggested by forestpiskie, try top first. If that does not reveal anything, I personally would try creating a fresh new user and try using that account to see if that makes a difference - if it does help it probably means some old settings for compiz/unity could be a problem. – gokul Apr 28 '12 at 7:49
I have the same problem. It takes me several clicks to do anything. I have to click atleast 3 times to go from one window to another. It takes a double click to move the cursor from one place to another. The new release is just slow. – W.K.S May 23 '12 at 20:02

I had a problem with an upgrade a few years ago that made my laptop unusably slow. I eventually found the problem was a malfunctioning CPU frequency governor, which meant my system never got off its lowest CPU frequency. The problem went away when I made the system use the conservative governor by default instead of the ondemand one. For more on frequency scaling, see for example:

share|improve this answer

My recommendation is, if you can, back up all your files to an external drive, download the 12.04 CD, and do a clean install. Then you can restore your files from the external drive.

Another possible solution, if you don't mind going under the hood, would be to install a second hard drive in your computer and do a clean install of 12.04 on that.

share|improve this answer

I had the same problem. Fixed it with resetting unity (unity --reset) and logging in on 'gnome without graphical stuff'. That worked for me. So it probably has something to do with old settings and new unity. Not sure though :), hope it helps to get your system running again.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.