Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

According to the user guide, I need to install the driver that is present on the dongle. But when I insert the dongle, nothing is showing up. The green light on it is blinking, though. It's getting detected in Windows 7 properly.

share|improve this question
add comment

5 Answers

  1. connect MTS in a Windows 7 system for the first time, and a CD drive will be mounted.

  2. Don't install the software, open the MTS CD Drive, find a file with .deb extension

  3. It is the debian driver file which we need to install

  4. Copy/Paste the debian file into Ubuntu Home, open terminal and run the following command

    sudo dpkg -i packagename.deb
    

    mention the package name correctly.

  5. Easiest way would be double clicking the deb file, which opens UBUNTU software installer, but many times it returns an error

  6. Don't bother about the modem disconnected error. I too get it quite often. Sometimes it takes 10-20 minutes after many trials. Connect the device first and then start the system. Don't know the technical reason behind this. But I get connected in 2 or 3 attempts by doing this.

share|improve this answer
add comment

Ubuntu is so powerful that it can detect any Modem. You need to do just proper setting to use it. For Mblaze Customer Care no. are (Call no. as per your state and city)

Bihar: 9135-955-955
Delhi: 9136-955-955
Haryana: 9138-955-955
Karnataka: 9141-955-955
Kerala: 9142-955-955
Kolkata: 9153-955-955
Maharashtra: 9145-126-126
Mumbai: 9146-126-126
Pune: 9146-126-126
Rajasthan: 9667-955-955
Tamil Nadu: 9150-955-955
West Bengal: 9153-955-955

Ask Customer care and note details of

  • APN:
  • Username:
  • Password:
  • Dial Number:

I suggest you to ask these details because it can change as per different state.

  1. Click in network manager (See in top right panel)
  2. Click on "edit connections" then go to mobile broadband
  3. Click on "Add". Select India as a country and MTS as a provider.
  4. Now go to mobile broadband tab. Edit details that provided by customer care.

You will be able to connect Internet through mblaze. No need to other software or driver.

share|improve this answer
add comment

For MTS devices no driver need to be installed in Ubuntu. It is automatically detected. You need to set up user name and password to get connected.

  1. Click in network manager (See in top right panel)
  2. click on "edit connections" then go to mobile broadband
  3. Click on "Add". Select All details like country and provider.
  4. Now goto mobile broadband tab. Provide user name [user name is - internet@internet.mtsindia.in ] and password [password is - mts].
  5. Now try to connect. Click on network manager and select your connection

Let us know if you have face any difficulties.

share|improve this answer
    
I did everything but I'm still getting a 'Modem Disconnected' error in the end. –  Uday Kanth Apr 28 '12 at 8:23
    
even I got the same results as Uday Kanth does it have some thing to do with usb_modeswitch –  Registered User Mar 10 '13 at 15:15
add comment

open up the terminal and enter 'su' to get root access. Then type 'lsusb' and it will list all usb devices mounted. Then type: 'echo ''1c9e 9605'' > /sys/bus/usb-serial/drivers/option1/new_id'. Replace ''1c9e 9605'' by the bus and device number shown in output of lsusb. Now the problem will be solved.

share|improve this answer
    
Generally entering su won't give you root access because the root-account isn't enabled. Use sudo su instead. –  MadMike Nov 18 '13 at 7:27
add comment

The following worked for me:

  1. Click on the network connection icon in the upper right corner of the desktop.

  2. Then go to Edit connections->Add->Connection Type-> and selected Mobile Broadband->Select Service Provider, configure and Save.

  3. The trick comes after. Now that we have created the connection, we have to enable it, and here is how we do it:

    On the network connections menu, an option - Enable mobile broadband will show. Check that option and voila, your MTS is now up and running.

Hope this helps, Happy Browsing!!!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.