Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I reinstalled xubuntu on my good ol' laptop from 2005, and everything works great! The only problem is that video is slow/choppy - on the order of 4-10 frames a second, depending on the video. I used to stay up late in bed watching shows like Arrested Development and The Wire on this laptop, so not having video is a huge bummer.

I've tried lowering my resolution, and using different media players, like vlc and mplayer. That seems to help a little, but not enough to make videos watchable.

Another thing I noticed is the proprietary video drivers aren't available anymore - if there is any way to install these things again, that might work. I'm willing to get my hands dirty, but I'm not sure where to get started with something like that. Back in the ubuntu 8.04 days, the proprietary drivers loaded themselves automatically, but now they don't work at all.

The other thing I could try is re-encoding my videos somehow. That's something I don't know where to start with, so if anyone has any advice, I'd love to hear it. I did manage to install handbrake, but the options are kind of overwhelming, and I'm not sure where to start.

TL;DR I could use help either a) installing old, unsupported proprietary drivers or b) somehow re-encoding videos to be easier on my processor maybe?

share|improve this question
add comment

2 Answers 2

up vote 2 down vote accepted

Pop into Menu -> Settings -> Settings Manager -> Window Manager Tweaks, click on Compositor and turn Compositing OFF...

This may help playback a little, failing that you could recode the movies to a simple .avi by using a program called Transmageddon which is very simple to use and in the repo's...

BTW, which graphic card does your laptop use ?

share|improve this answer
    
The laptop uses "ATI Mobility RADEON 9000" . Turning off Compositing actually fixed half of my problem! Videos from the hard drive now run perfectly. Thanks! Flash is still choppy, however. –  Jesse P Apr 28 '12 at 16:27
add comment

Before doing all that, have you tried switching to unity 2d? Seems to help when people are experiencing performance issues.

share|improve this answer
    
I'm using xfce (xubuntu) - unity was too slow for me. –  Jesse P Apr 28 '12 at 5:35
    
whoops so sleepy I missed that, sorry –  Rich Apr 28 '12 at 5:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.