Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

A brief electrical outage interrupted my 12.04 upgrade. After many tries, which included trying to upgrade from a command line, I was able to access Ubuntu screens again.

I find that the 12.04 upgrade was indeed not completed; I am still running 11.10. However, Update Manager does not give me the option of installing 12.04 now.

And, when I run Update Manager, I am asked if I want to execute a "partial install." When I answer "yes," I receive the message above. Besides a clean install, any ideas about what can I do to upgrade to 12.04?

share|improve this question
1  
Can you please post output of gedit /etc/apt/sources.list?:) –  Tachyons Apr 28 '12 at 7:01
add comment

3 Answers 3

It means your upgrade crashed during the failed system upgrade.

Try this:

  1. Press Ctrl+Alt+T to open a Terminal window.

  2. Run these commands:

    sudo rm -rf /var/lib/apt/lists/*
    sudo apt-get update
    

    That might be sufficient to fix the problem. If not, continue on...

  3. Run the command

    gksu gedit /etc/*release
    

    and change everything in the file gedit brings up to:

    DISTRIB_ID=Ubuntu
    DISTRIB_RELEASE=11.10
    DISTRIB_CODENAME=Oneric
    DISTRIB_DESCRIPTION="Ubuntu 11.10"
    

    Save the file.

  4. Then run this command.:

    gksu gedit /etc/*issue
    

    And change the file to to:

    Ubuntu 11.10 \n \l
    

Now open the Update Manager and upgrade the OS as usual.

share|improve this answer
    
yes when I was upgrading and it crashed.I tried in terminal sudo rm -rf... and nothing, tried the next one lsb_ rel... and it said release: 12.04 codename :precise Thanks for your helps –  CARLOS Apr 16 '12 at 3:12
    
Please post output of gedit /etc/apt/sources.list –  Tachyons Apr 16 '12 at 3:51
add comment

Try running sudo apt-get dist-upgrade.

share|improve this answer
add comment

Did you try sudo do-release-upgrade -d?

You didn't say if you're running a 32-bit or 64-bit system, as there are known issues with either involving ia32-libs and multiarch in upgrading to 12.04 beta2. (I assume you're upgrading to beta2?)

Detailed information is at:
https://wiki.ubuntu.com/PrecisePangolin/TechnicalOverview/Beta2#Upgrades

share|improve this answer
add comment

protected by Community Jul 19 '12 at 6:27

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.