Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I have to run Juniper VPN on the 64bit Ubuntu 12.04. I have installed openjdk-7-jre, openjdk-7-jdk and icedtea-7-plugin. After the browser prompts to install the Juniper VPN, I check it has been successfully installed to "/home/huangyun/.juniper_networks/network_connect".

I open the Firefox from command line and check the log:

Launching "/usr/lib/jvm/java-6-openjdk-amd64/jre/bin/java" "-classpath" "/home/huangyun/.juniper_networks/network_connect/NC.jar" "NC" "-h" "extranet.scei.a-star.edu.sg" "-L" "0" "-l" "0" "-n" "" "-t" "" "-x"

I run the above command manully:

$ java -classpath ~/.juniper_networks/network_connect/NC.jar NC -h extranet.scei.a-star.edu.sg -L 0 -l 0 -n "" -t "" -x
Failed to load the ncui library.
Quitting.

I check the file libncui.so and found that the .so file is 32-bit version:

$ file libncui.so 
libncui.so: ELF 32-bit LSB shared object, Intel 80386, version 1 (SYSV), dynamically linked, stripped

I can not recompile the 32-bit .so file to 64-bit, so I think I have to install 32bit Java on 64bit Ubuntu 12.04. Could you please tell me how to do it? I have searched the web but find little information.

share|improve this question
    
Good research to decide that you need the 32-bit java. :) –  Limited Atonement May 21 '13 at 13:58
add comment

marked as duplicate by user68186, Uri Herrera, Eric Carvalho, Basharat Sial, Kevin Bowen Jun 4 '13 at 2:35

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

3 Answers

up vote 2 down vote accepted

Juniper used to require Oracle Java, due to a bug in OpenJDK.

Refer : https://github.com/flexiondotorg/oab-java6

to install java.

share|improve this answer
    
It really works for me! Thank you very much. –  Yun Huang Apr 29 '12 at 7:11
    
I am using ubuntu-12-10-64. I tried the default sun-java-6, it didnot work. Then I tried the Oracle-7, even then it didnot work. However, in my office, I was able to setup the juniper-vpn-client on a ubuntu-12.04-32bit machine. Any suggestions. –  Vivek Sharma Mar 31 '13 at 11:20
add comment

To answer the original question:

On 12.04 and 12.10, it is possible to install i386 packages on amd64 by appending ":i386" to the package name when running apt-get. So, for example, while running an amd64 Ubuntu 12.04 Live CD, I ran:

sudo apt-get remove firefox openjdk-6-jdk icedtea-6-plugin
sudo apt-get install firefox:i386 openjdk-6-jdk:i386 icedtea-6-plugin:i386

And could then successfully log into the VPN.

Since 12.04, Juniper VPN will work on OpenJDK 6 out-of-the-box but only on i386. There was a bug in the icedtea plugin that was preventing this from working previously. I have verified that this is fixed using an i386 Ubuntu 12.04 Live CD.

I am surprised that the amd64 Oracle JDK is working for you. However, I have not yet tested it myself, but when I do I will update this answer. It would be good if you can confirm exactly what packages you are now running.

It is worth noting that there is an optional part to the Juniper VPN login process called the Host Checker that may or may not be configured on the VPN server you are connecting to; it enforces security policies on Windows computers but still has to run on Linux to check what OS you are using. This could result in differing reports of success from different people. For reference, the VPN I use does have the Host Checker enabled.

In your original question you state that you were installing Java 7 packages, yet your log shows you are using Java 6 in Firefox. If you have multiple JDKs installed, you need to be clear which on you are using.

For reference, there is also a very long-running thread on the Ubuntu forums on Juniper VPN.

Update

I have now tested the amd64 Oracle JDK and it wouldn't work for me. So as far as I can see, installing the i386 version of the Oracle JDK or Open JDK is the only way to get it working.

share|improve this answer
    
Worked for me on 12.10 -- updated answer text to reflect this. –  belacqua Jan 30 '13 at 19:50
    
After logging in, Juniper apparently runs some host checking code. My computer was getting stuck on this page. The URL was https://(host on my company's network)/dana/home/starter0.cgi?check=yes I just changed check=yes to check=no and reloaded the page, and everything worked from there! –  Pierre Apr 16 '13 at 18:23
add comment

Using the instructions here: http://www.rz.uni-karlsruhe.de/~iwr91/juniper/ I have juniper VPN running on Ubuntu 12.04 64bit with no 32 bit software installed except for these 3 libraries:

sudo apt-get install libc6-i386 lib32z1 lib32nss-mdns

I start the jnc perl script use the --nox option (no gui) and it works great, I use it everyday.

I originally downloaded the cert file using Firefox 64-bit: Tools>PageInfo>Security>View Certificate>details>export

I have since found this script that does the same: https://github.com/udomsak/juniper-ncui/blob/master/getx509certificate.sh

My particular configuration file required host, user, realm, and certfile. Yours may be different.

The certfile location configuration required the full path name, ~ did not expand to /home/username

share|improve this answer
    
I tried this first because it was faster than changing to Java 32 bits and IT WORKED! Thanks man. –  elgalu Jan 19 at 12:44
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.