Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I boot up or log into gnome-classic (no effects), windows don't have the frame around them that has the minimize and close buttons and all that. After that, there all sorts of issues - for example, when I open a new window, it's in the very top left corner, obscuring the menu on the gnome panel... just a whole bunch of minor annoyances.

I can get things working by by loading the compiz fusion icon and then selecting to reload the window manager.

Of course this is less than ideal. How do I get the window manager to load automatically?

Update: It seems that I get no window manager whenever I load Compiz, even after logging in. So it looks like the problem is more generally with Compiz's window manager.

share|improve this question
    
I have this problem too and compiz --replace doesn't help. I'm running lightdm, could that be the problem? Also, where could I tell gnome-classic which window manager it should use? –  Kris Sep 24 '12 at 9:50
add comment

3 Answers 3

up vote 1 down vote accepted

As of September 2012, this problem was resolved automatically with subsequent updates to Compiz.

share|improve this answer
add comment

Go to > system > preferences > start up applications.

Create a new application launcher and add.

Make sure the command is compiz --replace so it starts every time

enter image description here

share|improve this answer
add comment

First install dconf editor OR tweak (advanced settings) to add the extra buttons on the title bar

For the windows manager problemn, if you think that for some reason it's related to lightdm, try installing gdm.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.