Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

If I attach an USB keyboard (I usually do it before turning the computer on), then detach the keyboard and attach an USB HDD, it takes very long for the HDD to be detected and mounted and after all it works only as USB 1.1. Is there a way to make it work as a correct USB 2.0 port again without rebooting?

share|improve this question
1  
Are you sure that port in 2.0 complaint? –  OpenNingia Nov 11 '10 at 14:19
    
@openningia I am absolutrly sure all my USB ports are USB 2.0. But booting a PC with a keyboard attached to a port makes it USB 1.1. If I reboot without a USB keyboard, it becomes a perfect USB 2.0 again. –  Ivan Nov 11 '10 at 20:17
    
Is this a somewhat older PC? You can try to disable legacy USB support in the BIOS, but then you might not be able to use the keyboard in GRUB (or not even the BIOS anymore, in some cases, so best keep a PS/2 keyboard or PS/2-USB converter around). –  JanC Nov 12 '10 at 4:15
    
This actually sounds like your HDD might be corrupted - what filesystem is it formatted with... NTFS? –  Nathan Osman Feb 5 '12 at 6:36

1 Answer 1

sudo /etc/init.d/udev restart

Should help. You attach the USB HDD and then unmount it, after that you use what's above.

share|improve this answer
    
"attach the USB HDD and then unmount it" usually means many minutes waiting for it to get detected and mounted. –  Ivan Nov 11 '10 at 20:21
1  
I've tried doing the whole way exactly as you write - no difference: same long time to detect and mount, same slow operation. –  Ivan Nov 11 '10 at 21:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.