Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I did a clean install '12.04_amd64 3 times with the same results each time. Installation went without problems, I did all my updates, installed aptitude, synaptic, changed server locale, started adding multimedia apps when everything went blank and logged out. No error messages. Login screen only allows guest access. I reinstalled 11.10_amd64-no problems now. Second and third install gave same results. The only root access is by tty. This is the most unusable version I've had in the 6 years I've been using Ubuntu.

  • Asus P7P55D-E mainboard
  • Intel I5-750 processor
  • Western Digital 1 tb. Caviar 'black' hdd
  • old WD 160 gb. hdd
  • 8gb 1600 'ripjaws' memory
  • Nvidia 9800GT gpu
  • triple boot: Ubuntu 12.04_amd64, Windows 7 Professional, Windows XP Professional-Precise and win 7 shared 1tb hdd, xp on 160 gb.

I found this message on /var/log/lightdm/lightdm.log:

session 1839: Sending SIGTERM session 1839:exited with return value 0 Greeter quit

share|improve this question

closed as too localized by RolandiXor, Jorge Castro, fossfreedom Nov 13 '12 at 16:32

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
This question should instead be filed as a bug report, and as such is off-topic, thanks! Instructions on filing a bug report are here. –  Jacob Johan Edwards Apr 28 '12 at 6:21
    
Well excuse me! I never stated that I was finished with 12.04; I simply returned to Oneiric as a temporary measure until this problem is solved. I posted here hoping to get assistance or at least some suggestion as to a solution, not to be chastised like a schoolboy. I was led to believe 'Ask Ubuntu' was the place to be for solutions-obviously I was mis-informed. –  dangmc Apr 28 '12 at 14:08
    
I did not intend to offend or dismiss. AskUbuntu is, indeed, a place for solutions. This question addresses recovering from, in essence, a bug, and it's basically impossible to debug problems that are not reproducible and that the original reporter has given up and downgraded away from. I've nominated your question for reopening, nonetheless. Best wishes. –  Jacob Johan Edwards Apr 28 '12 at 15:05
    
This seems to be the solution to your problem here - askubuntu.com/questions/70236/… –  jrg Apr 28 '12 at 15:10
    
@jrg Thank you for your suggestion. I'm going to reinstall 12.04 on my old xp drive since I really don't need xp anymore; I will then try your suggested fix/workaround. My gut feeling is that we have a bug in Lightdm; not a problem with permissions because admin account was available through multiple reboots-then without warning 'auto' logged out to guest screen. Admin was no longer accessable neither cli or gui.@Jacob-thank you for positive comment. I would have filed bug rep-couldn't do it through console. –  dangmc Apr 28 '12 at 17:53

1 Answer 1

Solved with temporary fix: Installed updated nVidia driver 302.07, installed gdm, removed xserver-xorg, reinstalled xserver-xorg from console with these commands:

sudo stop lightdm
sudo apt-get purge nvidia*
sudo apt-get install gdm
cd Downloads
sudo sh ./NVIDIA-Linux-x86_64-302.07.run
sudo dpkg-reconfigure gdm
sudo apt-get purge xserver-xorg
sudo apt-get install xserver-xorg xserver-xorg-video-all
sudo start gdm

Installing the nVidia driver I just went with all the defaults; set gdm as default.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.