Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My attempt to upgrade to 12.04 failed, so I burnt a 12.04 CD, and asked to do a full install, getting rid of all previous OS (I had Windows as well as 11.10). All seemed well until the very end when it said it had failed to install GRUB. I tried selecting different partitions to try in, with the same result. I can proceed without installing GRUB, but then it tells me I have to manually install the boot loader. A long Google session has failed to come up with any instructions to do this that I can understand. Help.

share|improve this question
1  
If the answer below works for you, great! If not, it would help to have more info about what your system looks like. Please consider using the Boot-Repair tool to collect & post this info. I tried to outline how to do that here –  irrational John Apr 28 '12 at 0:13

2 Answers 2

Nothing about GRUB makes sense to a large number of users. Here's what I'd do.

  1. Boot the machine using a Live CD.

  2. Open a terminal.

  3. Find out the name of the internal disk by using fdisk to look up the device's size.
    For example:

    sudo fdisk -l
    
  4. Install GRUB boot loader onto the proper disk (the example below assumes it is /dev/sda):

    grub-install --recheck --no-floppy --root-directory=/ /dev/sda
    

Hope this helps.

share|improve this answer
    
"Nothing about GRUB makes sense to a large number of users." What is that supposed to mean? If it wouldn't make sense then your solution wouldn't work. It's either the installer (look at the install logs), the partition layout (logs again) or the UEFI implementation (you bought crappy hardware, return it) that is to blame. GRUB is just issued to install to the target and the installer doesn't handle failures gracefully. –  LiveWireBT May 12 at 9:14

i've done it!

when partitioned the hard disk, i set up /dev/sda1 a very small partition, a 20MB primary, of course, then all the other partitions logical. carefully set the device for the boot loader /dev/sda1 , NOT /dev/sda ! to be more sure, i left a small unpartitioned space at the end of the hard disk, less than 100MB. the idea is that no one likes /dev/sda , not even the computers! it seems /dev/sda is not a device, but some strange entity. to do the job it seems you need a true device at the beginning of the disk, or less probable some empty space which would stand for /dev/sda.

installed ubuntu 13.10 on a Acer Aspire 5310 Laptop. worked! wasted few hours to find the solution. it was try and fail, one after another...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.