Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I’m trying to set an alternate keyboard layout, but I’m having trouble doing so. I chose "Deutsch (Neo2)" during installation of 12.04, and this is the only layout I need. I have Ubuntu on my laptop (Lenovo X121e), where the layout works fine, and on my desktop, where I also chose it during installation. But here, it changes back to American Layout after reboot, although the layout dialog claims it to be "Deutsch (Neo2)". When I select it, it does changes to Neo. However, all the shortcuts for Unity stop working, e.g. Alt+Tab, or Ctrl+Alt+Right to change workspace.

share|improve this question
add comment

3 Answers

It is an only one bug I have found so far as well. Here is my temporary fix: Alt+Shift to toggle between Norwegian and Thai keyboards.

sudo setxkbmap -option grp:alt_shift_toggle no,th
share|improve this answer
add comment

I have a similar problem, and the setxkbmap command worked well. The problem is not fixed however, Ubuntu 12.04 has problems with setting keyboard language.

Ive seen many threads on this and almost every time the answer is to change the keyboard language in system settings > Keyboard Layout. The case is however, this is not why I am having problems, I do all this and yet it sticks to keyboard language that is not norwegian.

For that matter, I were stuck with english regardless what I did. Now what I did was adding swedish keyboard language, then removed norwegian. So swedish worked, so I added norwegian and set it to norwegian. The language now stuck to swedish.

Phnakarin's method in terminal worked well though. I installed swedish and english US keyboard and did this: udo setxkbmap -option grp:alt_shift_toggle no,se,us

Only posting this to highlight two things, the setxkbmap method works. And that there's a bug with keyboard language GUI module.

share|improve this answer
add comment

I had the same problem with switching between input languages. I set up CTRL+SHIFT method of switching between layouts during Ubuntu installation. However this shortcut didn't work and I had to switch layout manually by clicking the appropriate icon on the upper Gnome/Unity tool-bar.

Recently I found the solution:
Go to the upper tool-bar keyboard menu -> Keyboard Layout Settings -> Options -> Key(s) to change layout -> choose your shortcut (in my case the shortcut CTRL+SHIFT wasn't marked) -> VOILÀ! everything works!

P.S. You may reach this "Options" menu from System Settings -> Keyboard Layout -> Options...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.