Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After installing 12.04, the headphone plug no longer mutes my external speakers.

-Sound settings - Analog Output - Analog Stereo Duplex Mode - Test Sound

Left Front sounds thru Left external speaker

Right Front sounds thru Right Headset

share|improve this question

1 Answer 1

This sounds like something you can configure using the alsamixer.

Open up a terminal, and simply type in "alsamixer". On the right side of the various volume controls, you should see an "automute mode". Simply tap the up arrow key on your keyboard to enable it, and then press escape.

If there is no "automute mode" on the mixer, then you can manually mute the speakers when you have your headphones plugged in, by simply highlighting the channel that has the speakers attached and pressing the "m" key.

For future reference, please post the specific hardware you are using when you're having a problem. It makes diagnosing things much easier, because we can look for known bugs.

Cheers!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.