Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've a C-Media sound card - CM8738 and 5.1 speakers.

Everything seems to work pretty good, but there is a problem - two speakers are mixed - subwoofer is a central speaker, and central speaker is a subwoofer for Ubuntu.

share|improve this question

1 Answer 1

1- Run in terminal gksu gedit /usr/share/pulseaudio/alsa-mixer/profile-sets/default.conf This is the file where the channel map is, enter you pasword when prompted, and the file will open.

2- You are looking for the code that looks like this-

[Mapping analog-surround-51]
 device-strings = surround51:%f
 channel-map = front-left,front-right,rear-left,rear-right,front-center,lfe
 paths-output = analog-output analog-output-speaker analog-output-desktop-speaker analog-output-lfe-on-mono
 priority = 8
 direction = output

3- It may not be exactly the same, but we want to change only the channel-map order
from -
channel-map = front-left,front-right,rear-left,rear-right,front-center,lfe
to -
channel-map = front-left,front-right,rear-left,rear-right,lfe,front-center

Notice the order on lfe and front-center, lfe is the subwoofer, and front-center is your center speaker, if it displays another configuration, just swap position of lfe and front-center

Source: http://ubuntuforums.org/archive/index.php/t-1484966.html

Let me know how this works for your version.

share|improve this answer
    
Now pulseaudio don't want to work. Sound settings don't see any sound card. –  Michał Leśniowski Apr 28 '12 at 6:57
    
I did. Ubuntu 12.04, but it didn't worked on previous versions also. I don't have amplituner, it's normal sound system from Creative so I guess, I will have to buy new sound card. Bad news. But I still have some hope. –  Michał Leśniowski Apr 28 '12 at 20:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.