Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

VM program: Virtual Box 4.1.12

Host OS: Windows 7

Guest OS: Ubuntu 11.10

I am unable to use my webcam (my laptop is Lenovo Z470) in the Ubuntu VM. Most other devices work perfectly fine. I have installed Guest Additions and I use Ubuntu in seamless mode. I am also able to use shared folders. When it comes to USB devices, I am able to mount USB mounted on my host OS onto my guest OS. I can also use my Epson scanner which connects to my laptop through a USB cable.

By default my laptop webcam is undetected by my guest OS Ubuntu. I go to Devices>>USB Devices>>Unknown device OBDA:58EA [2520]. When I click on it a new device is detected and it appears as Devices>>USB Devices>>LOEAAI10P2SF00721W05636 Lenovo easy camera [2520]. I click it to enable it (a tick mark appears to its left). So far so good.

Then when I start Skype, in Options>>Video Devices I am able to select webcam Lenovo easy camera (/dev/video0). Unfortunately, in spite of the Enable Skype Video option being ticked, I am not able to test the webcam or use it in Skype conversations. I can click the Test button in Skype>>Options>>Video Devices but I see no picture. The led which is associated with the webcamera fails to turn on too.

share|improve this question
1  
i suspect a skype/v4l vs v4l2 problem not a virtualbox problem. try booting live and see if the problem still evidences –  hbdgaf Apr 27 '12 at 18:48
    
Is there a way I can use my webcam to take snapshots? Like a profile picture or something? That way I can ascertain whether or not Skype is the cause of the problem. Thanks for the suggestion though! –  Shashank Sawant Apr 27 '12 at 21:59
    
Update: I installed "cheese" but still no success. Then I installed VirtualBox extension package and enabled EHCI support. Still the webcam doesn't work. –  Shashank Sawant Apr 27 '12 at 22:32
    
I still haven't found a solution to it. –  Shashank Sawant Jun 21 '13 at 17:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.