Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Translation:

I did some configurations with compiz, nothing to crash(?) unity. After that I turned off the computer, turned it back on and tried to connect my monitor in extended mode and it gave me the following error:

the position or size required for the CRTC 148 is outside the allowable limits: position = (1366, 0), size = (1366, 768), maximum = (1600, 1600)

GDBus.Error: org.gtk.GDBus.UnmappedGError.Quark._gnome_2drr_2derror_2dquark.Code3: the > position or size required for the CRTC 148 is outside the allowable limits: position = > (1366, 0), size = (1366, 768), maximum = (1600, 1600)

Can anyone tell me how to solve this problem?

Original:

Hice algunas configuraciones con el compiz, nada que me tumbara el unity, despues de apagar el equipo y volverlo a encender, intente conectar mi monitor en modo extendido y > me da el siguiente error:

la posición o tamaño requeridos para el CRTC 148 está fuera de los límites permitidos: > posición=(1366, 0), tamaño=(1366, 768), máximo=(1600, 1600)>

GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._gnome_2drr_2derror_2dquark.Code3: la posición o tamaño requeridos para el CRTC 148 está fuera de los límites permitidos: posición=(1366, 0), tamaño=(1366, 768), máximo=(1600, 1600)

¿Alguien me puede decir como solucionar el problema?

share|improve this question
    
Were you able to successfully connect your second monitor before you changed the compiz settings? –  jamesadney Apr 27 '12 at 19:01
add comment

4 Answers

I had a similar problem on my system and could not fix it using Catalyst.

In the end I expanded the Maximum Virtual Screen by adding

Virtual 4096 4096 to the Display Subsection of my /etc/X11/xorg.conf:

     SubSection "Display"
            Virtual         4096 4096
            Viewport   0 0
            Depth     24
    EndSubSection

After rebooting I was able to use Ubuntu's display manager to enable multiple monitors. 4096x4096 might be to large for some graphics cards, if it is just scale it to what you need.

share|improve this answer
add comment

Run gksudo amdcccle.

Display Manager> Choose multi-display dekstop with display(s) from the combobox and restart the computer it will fix. You still can't use the real monitor settings.

share|improve this answer
add comment

This is what worked for me: Reboot with external monitor attached. Login & Unity worked fine after that.

Ubuntu 12.04 fresh install HP G42 PC AMD

share|improve this answer
add comment

The same problem happens to me, and I use a nvidia card (nvidia driver 295.40), on a Sony Vaio laptop, with Ubuntu 12.04.

To solve the problem, instead of accepting the resolution of each monitor as "auto", I've changed them both to the actual resolution (in my case both are 1920x1080).

So, my xorg.conf was something like: Option "metamodes" "DFP-0: nvidia-auto-select +0+0, DFP-1: nvidia-auto-select +1920+0"

Now it has the resolutions fixed: Option "metamodes" "DFP-0: 1920x1080 +0+0, DFP-1: 1920x1080 +1920+0"

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.