Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Thank you for reading. I am still having issue with power regression on my Asus K53SV after doing a fresh install of Ubuntu 12.04 (I have this issue with Ubuntu 11.10 as well). Thus a helpful guy told me to check my drivers. Now, my graphic driver itself is a problem. I have two problems now :(

If I go to System Settings > Details > Graphics, it shows "Graphic Unknown".

And if I go to System Settings > Additional Drivers, it returned nothing in the list and only with a description "No proprietary drivers are in use on this system".

I have my Windows 7 as my primary OS, I install Ubuntu using Wubi and dual boot them. My battery last for 4-5 hours on Windows 7 but only 2 hours on Ubuntu. My screen resolution in Ubuntu is 1366x768(16.9) even without bothering about Nvidia thing. The very first time I installed Ubuntu 11.10 using Wubi I can see there are NVidia drivers appear as a list under Additional Drivers, but no longer seeing it after the second installation of my Ubuntu 11.10. :(

I would really hope to fix the NVidia issue so that I can see if it helps in settling my power regression issue. Your kind inputs/comments would be very much appreciated. Thank you. :)

*Edit: I have added updates to my situation down there. It's getting better yet complicated as well :/

share|improve this question
    
So what's again the output of : lspci | grep VGA –  Hanynowsky Apr 27 '12 at 19:47
    
I have the same issue with my Asus N73SV. Here's the output of lspci: root@theta:~# lspci | grep VGA 00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) 01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 540M] (rev ff) –  David Apr 29 '12 at 3:46
    
Hi Hanynowsky, sorry for the late reply. My result is as below: 00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) 01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 540M] (rev a1). Thanks for the willingness to help :) –  Shyuan May 1 '12 at 0:50
    
@Hanynowsky I have referred to this Bumblebee tutorial in this link. It seems helpful. I did it, and I got 1 or 2 hours extra. However, the time left is very fluctuating. So I am not too sure if my problem is solved? Can you please take a look at the link and see if it will work (in your opinion) for my laptop? And, what about the Optimus you told me? Your reply would be much appreciated :) Thanks a million :) –  Shyuan May 1 '12 at 3:14
    
@Shyuan sorry for the delay. Very busy these days! I reply to you in few minutes! –  Hanynowsky May 1 '12 at 21:28

2 Answers 2

up vote 1 down vote accepted

To know if you're using the Intel HD 3000 (Main Graphics card), append in Termina the following:

/usr/lib/nux/unity_support_test -p

You should get a similar result as the following:

OpenGL vendor string:   Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel(R) Sandybridge Mobile 
OpenGL version string:  3.0 Mesa 8.0.2

Not software rendered:    yes
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  yes
GL npot or rect textures: yes
GL vertex program:        yes
GL fragment program:      yes
GL vertex buffer object:  yes
GL framebuffer object:    yes
GL version is 1.4+:       yes

Unity 3D supported:       yes

Try again with the nvidia card (that, if Bumblebee is successfully installed):

optirun /usr/lib/nux/unity_support_test -p

You should get:

OpenGL vendor string:   NVIDIA Corporation
OpenGL renderer string: GeForce GT 525M/PCIe/SSE2
OpenGL version string:  4.2.0 NVIDIA 295.40

Not software rendered:    yes
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  no
GL npot or rect textures: yes
GL vertex program:        yes
GL fragment program:      yes
GL vertex buffer object:  yes
GL framebuffer object:    yes
GL version is 1.4+:       yes

Unity 3D supported:       no

Know that The Nvidia card is not compatible with Unity 3D. The Intel HD 3000 is. That means that if you're using Unity 3D now, it's the Intel card which is in use. And the fact The Graphics Driver name does not appear in Systems Settings (Details), stipulates there is some conflict between drivers (Proprietary drivers of Nvidia or Nouveau). Purging them and reinstalling bumblebee seems a solution (Bumblebee will resintall Nvidia drivers nvidia-current for you). The correct result should look this:

System Overview OR: Graphics used

You quoted : "And if I go to System Settings > Additional Drivers, it returned nothing in the list and only with a description "No proprietary drivers are in use on this system"." -> This is normal when you install Bumblebee and normal when the Nvidia card is not activated and not recognized by the system. I am having the same thing and it's not an issue. You can trace eventually what happens in the video log: /var/log/Xorg.0.log

For your other tweaking needs. As you're new to Ubuntu, the best way to achieve some tweakings for your whole desktop is to install the application: UBUNTU TWEAK, this way:

sudo add-apt-repository ppa:tualatrix/ppa

then

sudo apt-get update && sudo apt-get install ubuntu-tweak

Ubuntu Tweak Login Tweaking unlocked

share|improve this answer
    
I did all the above. they are exactly the same. Two minor things i noticed, when the Unity is in 3D mode, there is no alert sound (ie when i undo something in Terminal and "over undo", there is supposed an alert sound like "tok") and the icon hover is like this instead of the normal beautiful one. Previously when I still have nvidia installed, the Unity is not in 3D but i can hear the alert sound effect and also the icon hover is the original ones. Once back to Intel HD, they're gone. Do you have idea with what I said?:) –  Shyuan May 2 '12 at 21:08
    
I really don't understand well :) Are you talking about SYSTEM SETTINGS->SOUND->SOUNDEFFECTS ? What do you mean by undo and over undo? (Launching and killing a program from terminal?) I personally hear no sound when using terminal. Icon hover of what? Could you make screenshots and edit your questions so that we understand better? –  Hanynowsky May 2 '12 at 22:31
    
hiya, sorry for confusin you. I will explain one issue at once. if u launch your Terminal and press Backspace on your keyboard, do you hear any sound like the Default under System Settings > Sound > Sound Effects? Thanks. –  Shyuan May 2 '12 at 23:18
    
No I do not...... –  Hanynowsky May 2 '12 at 23:31
1  
Thank you so much for your help! I have been struggling with those minor problems how stubborn i am. Thank you for your perfect explanation and troubleshoot for my problems. Appreciate them a lot! :D –  Shyuan May 3 '12 at 4:03

Initially, I have a few problems:

  1. Under Graphics, the Driver is shown as Unknown
  2. Battery only able to run for 2 or 2.5 hours on Ubuntu (it runs 5 hours on Win7)
  3. No NVidia drivers are shown under Additional Drivers
  4. Unity is running in 2D mode

Today, I found a tutorial teaching us how to enable Bumblebee. I followed. My battery issue is fixed. It went up 1-2 hours extra. Power consumption reduced from ~2500mA to ~1500mA.

Then, I found this telling us to install mesa-utils in order to fix "Graphics > Driver Unknown" issue. I followed. My Graphic is then shown as "Graphic Intel SandyBridge Mobile". Also, I tried opened up my Additional Drivers. I finally saw NVidia Drivers listed under it! I activated the Recommended one and restart my laptop as required. My Unity is back to 3D!

It seems like all 4 problems are fixed. Unfortunately, when I went to System Settings > Display > Graphic, the Driver shows nothing. No longer "Unknown" or "Intel SandyBridge Mobile".

I am very new to Ubuntu, I put efforts in trying out all the fixes. I hope I did not ruin things here again this time.

  1. Can anyone please tell me if I am doing the wrong way?
  2. How can I know which graphic driver am I using now? Because if I go Additional Drivers again, it tells me "This Driver is activated but not currently in use" for NVidia accelerated graphic driver [Recommended]. A moment ago when my "Graphics Driver" was "Intel SandyBridge Mobile", my Unity was still in 2D mode. My Unity is back to 3D right after the activation of NVidia. Not too sure which one is being used.
  3. Everytime I reboot my laptop again, the NVidia driver list under Additional Drivers are gone and then came again, then gone again after another reboot. Weird.

Your feedback/help would be very very much appreciated!!

THANK YOU!

share|improve this answer
    
I suspect it to be a conflict between drivers as you manually installed the nvidia drivers. Sounds like you need to purge bumblebee and nvidia-current and reinstall bumblebee from scratch. But wait untill we figure out more trace! –  Hanynowsky May 2 '12 at 2:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.