Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using an Dell Latitude D830 with Ubuntu 12.04. Now, when I turn off the pc, Ubuntu doesn't halt completely sometimes. I think that is due to the latest Nvidia drivers, because in the past with Ubuntu 10.10 I installed the latest drivers released by nvidia and I had the same problem. By now, "messages" file / var / log is always empty. My video card is: NVIDIA Corporation G86M [Quadro NVS 135M] PC will not turn off even with "halt -p".

share|improve this question
    
do you see any ACPI errors in /var/log/dmesg ? –  Janus Troelsen Apr 27 '12 at 18:15
1  
This is the only strange message: [2.591986] [Firmware Bug]: Duplicate ACPI video bus devices for the same VGA controller, please try module parameter "video.allow_duplicates=1"if the current driver doesn't work. (but it's at boot and the current driver work) –  marste Apr 27 '12 at 19:23
1  
...Same with me: Dell 830, shutdown hangs. I found ist was dropbox that prevented shutdown. When i stop dropbox before shutdown it's ok. For the clean Solution? no idea! greetings guges –  user57438 Apr 27 '12 at 20:23
    
I actually removed dropbox and will now shut down properly.I also tried installing the latest available version, but without success. With which command you stop dropbox? –  marste Apr 28 '12 at 7:03
    
Unfortunately is not dropbox causing the problem. Although I do not have Dropbox, sometimes, the problem is the same. –  marste Apr 28 '12 at 10:10

2 Answers 2

up vote 1 down vote accepted

May be related to this bug seen on Dell m1330, though only seen if using a 32 bit install & nvidia drivers 295.XX - https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers/+bug/940564

Similar question here - Shutdown issues on my Dell XPS M1530

Possible solution other than going back to nouveau or downgrading to nvidia driver 290.20 - Dell Studio 1569 Cannot Shutdown in Ubuntu 11.10 or 12.04

share|improve this answer

I think I solved it by edditing the reboot options in the grub file. How? just edit /etc/default/grub and search for the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" and add the ACPI option force, to become GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force" This did the work for me. Hope it helps you guys too.

share|improve this answer
    
this worked on my pc. –  JCasso Oct 9 '12 at 10:10

protected by Community May 3 '12 at 11:26

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.