Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed ubuntu 12.04 and running gnome-shell. So far almost everything went fine, but Alt + Tab is not working. How can I get Alt + Tab working? or there is some other alternative?

share|improve this question

closed as off topic by Marco Ceppi Apr 27 '12 at 20:33

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
This has been reported as a bug already on LaunchPad Bugs are offtopic on this site –  Marco Ceppi Apr 27 '12 at 20:33

1 Answer 1

  1. Search the Ubuntu Software Center for "CompizConfig" or
    sudo apt-get install compizconfig-settings-manager
  2. Launch CompizConfig Settings Manager by pressing Alt+F2 and running ccsm. (This may also be run from a Terminal.)
  3. Click "Window Management"
  4. Enable either "Application Switcher" or "Static Application Switcher"

Lance's graphical guide: http://i.imgur.com/8LzO2.png

Edit: My answer sucked, but it was the only one. However, Lance's comment was helpful to many, so I changed my answer for future searchers.

share|improve this answer
    
Tried this, still not working. Hoping there will be a fix very soon for this bug. –  Amit Apr 28 '12 at 0:27
16  
try this: activate the application switcher in compiz imgur.com/8LzO2 –  Lance Rushing Apr 30 '12 at 16:28
    
@LanceRushing: Thanks a lot :) Enabling application switcher solves the issue for Gnome Classic session. Just for a note, Alt + Tab works fine in Gnome Classic (No effects) without any modification. –  Amit May 1 '12 at 2:26
    
Thanks, Lance Rushing. It solved the issuse :-) –  Maksym Kozlenko May 6 '12 at 21:04
    
This did not work for me on gnome-classic (same setting otherwise). The static window manager seems seems to be in conflict with metacity. I had to remove CCSM and reinstall gnome to get things on working condition again. –  Yossi Gil May 7 '12 at 17:24

Not the answer you're looking for? Browse other questions tagged or ask your own question.