Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgraded from Ubuntu 10.04 LTS to 12.04 LTS. It's more or less working.

But, Global Menus aren't working, and when I use HUD no results ever appear. (Example: I search for "F" (without the quotes)) and nothing is found in any application (Terminal, Home Folder,...)

I already did:

sudo apt-get install appmenu-gtk appmenu-gtk3 appmenu-qt

Then restarted, but nothing.

Any ideas?

  • I deleted ~/.config, ~/.gnome2, ~/.compiz-1, ~/.icons and a dozen other such directories (obviously not recommended, but whatever...), restarted, and still no change.

  • I have a NVIDIA GeForce GT 430 and am using the "post release updates" provided by the Additional Drivers panel in System Settings. Maybe this is related?

  • Uninstalled the drivers mentioned, rebooted using whatever vanilla detection scheme Ubuntu has going on, no change.

share|improve this question
add comment

1 Answer 1

up vote 9 down vote accepted

This happend to me aswell after upgrading to 12.04.

You should install indicator-appmenu Install indicator-appmenu which wasn't installed on my system (or was removed by the installer). After this my global menu was working perfectly. (May require a log out and in or restart to connect.)

 sudo apt-get install indicator-appmenu

To immediately apply without re-login restart Unity: Open a terminal and issue:

unity --replace
share|improve this answer
    
This works! Amazing. Thanks. –  conner_bw Apr 27 '12 at 18:41
    
+1 It works immediately after log-out/log-in. –  Stephane Rolland Sep 16 '12 at 16:43
    
This fixed the issue for me, too. Be warned that unity --replace did crash for me. Logout and re-login fixed the issue. –  Mikko Rantalainen Jul 3 '13 at 19:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.